aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2007-04-27 19:46:31 +0000
committerKoen Kooi <koen@openembedded.org>2007-04-27 19:46:31 +0000
commit30a2f55dc7195ae25ff931547e42778b15e114f3 (patch)
treec536b11b215ae181fec852e5765c8f5bac5873ec
parent72d423a6562a20e4ee34ec1f67520be39a56b327 (diff)
downloadopenembedded-30a2f55dc7195ae25ff931547e42778b15e114f3.tar.gz
empathy: merge with poky
-rw-r--r--packages/telepathy/empathy-0.1/.mtn2git_empty0
-rw-r--r--packages/telepathy/empathy-0.1/no-gnome.diff39
-rw-r--r--packages/telepathy/empathy_0.1.bb17
3 files changed, 56 insertions, 0 deletions
diff --git a/packages/telepathy/empathy-0.1/.mtn2git_empty b/packages/telepathy/empathy-0.1/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/telepathy/empathy-0.1/.mtn2git_empty
diff --git a/packages/telepathy/empathy-0.1/no-gnome.diff b/packages/telepathy/empathy-0.1/no-gnome.diff
new file mode 100644
index 0000000000..4dd4a96354
--- /dev/null
+++ b/packages/telepathy/empathy-0.1/no-gnome.diff
@@ -0,0 +1,39 @@
+diff -ur empathy-0.1.orig/configure.ac empathy-0.1/configure.ac
+--- empathy-0.1.orig/configure.ac 2007-04-25 23:05:40.000000000 +0100
++++ empathy-0.1/configure.ac 2007-04-27 17:10:29.000000000 +0100
+@@ -39,12 +39,12 @@
+
+ PKG_CHECK_MODULES(EMPATHY,
+ [
++ libxml-2.0
+ glib-2.0 >= $GLIB_REQUIRED
+ gobject-2.0
+ gtk+-2.0 >= $GTK_REQUIRED
+ gconf-2.0 >= $GCONF_REQUIRED
+ libglade-2.0 >= $LIBGLADE_REQUIRED
+- libgnomeui-2.0
+ libtelepathy >= $TELEPATHY_REQUIRED
+ libmissioncontrol >= $MISSION_CONTROL_REQUIRED
+ ])
+Only in empathy-0.1: configure.ac~
+diff -ur empathy-0.1.orig/libempathy-gtk/gossip-ui-utils.c empathy-0.1/libempathy-gtk/gossip-ui-utils.c
+--- empathy-0.1.orig/libempathy-gtk/gossip-ui-utils.c 2007-04-25 23:05:40.000000000 +0100
++++ empathy-0.1/libempathy-gtk/gossip-ui-utils.c 2007-04-27 17:06:48.000000000 +0100
+@@ -31,7 +31,6 @@
+ #include <glib/gi18n.h>
+ #include <gtk/gtk.h>
+ #include <glade/glade.h>
+-#include <libgnome/libgnome.h>
+
+ #include <libmissioncontrol/mc-profile.h>
+
+@@ -1307,7 +1306,7 @@
+ GError *error = NULL;
+
+ real_url = fixup_url (url);
+- gnome_url_show (real_url, &error);
++ g_warning ("TODO: gnome_url_show (real_url, &error);");
+ if (error) {
+ g_warning ("Couldn't show URL:'%s'", real_url);
+ g_error_free (error);
+Only in empathy-0.1/libempathy-gtk: gossip-ui-utils.c~
diff --git a/packages/telepathy/empathy_0.1.bb b/packages/telepathy/empathy_0.1.bb
new file mode 100644
index 0000000000..410acd01e3
--- /dev/null
+++ b/packages/telepathy/empathy_0.1.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "Empathy: a Telepathy based IM client"
+HOMEPAGE = "http://blogs.gnome.org/view/xclaesse/2007/04/26/0"
+LICENSE = "GPL"
+DEPENDS = "telepathy-mission-control libtelepathy gtk+ gconf libglade"
+RDEPENDS = "telepathy-mission-control"
+RRECOMMENDS = "telepathy-gabble"
+
+PR="r1"
+
+SRC_URI = "http://projects.collabora.co.uk/~xclaesse/empathy-0.1.tar.gz \
+ file://no-gnome.diff;patch=1"
+
+inherit autotools pkgconfig
+
+FILES_${PN} += "/usr/share/mission-control/profiles/*.profile \
+ /usr/share/dbus-1/services/*.service \
+ /usr/share/telepathy/managers/*.chandler"