aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2005-01-29 09:04:47 +0000
committerMichael Lauer <mickey@vanille-media.de>2005-01-29 09:04:47 +0000
commit2c1c364a07f5ae0666635ad4229f2deebb4b5118 (patch)
treedcfc4ec40d934753484443c003c82e5c3b9afa0c
parentf0c3f1f2e11453ff876ed3079bb6bde639d76c98 (diff)
downloadopenembedded-2c1c364a07f5ae0666635ad4229f2deebb4b5118.tar.gz
Merge bk://oe-devel@oe-devel.bkbits.net/openembedded
into r2d2.tm.informatik.uni-frankfurt.de:/local/pkg/oe/packages 2005/01/28 22:38:28+01:00 uni-frankfurt.de!mickeyl repair opie-help-en packaging BKrev: 41fb51afw4iqKav_CuElNk73w7d_SQ
-rw-r--r--packages/opie-help-en/opie-help-en_1.1.8.bb25
-rw-r--r--packages/opie-help-en/opie-help-en_cvs.bb2
-rw-r--r--packages/qte/qte-4.0.0-snapshot/add-qatomic.patch (renamed from packages/qte/qte-4.0.0-b1/add-qatomic.patch)0
-rw-r--r--packages/qte/qte-4.0.0-snapshot/fix-mkspecs.patch (renamed from packages/qte/qte-4.0.0-b1/fix-mkspecs.patch)0
-rw-r--r--packages/qte/qte-4.0.0-snapshot/fix-qwidget.patch (renamed from packages/qte/qte-4.0.0-b1/fix-qwidget.patch)0
-rw-r--r--packages/qte/qte-4.0.0-snapshot/fix-qwsmanager.patch (renamed from packages/qte/qte-4.0.0-b1/fix-qwsmanager.patch)0
-rw-r--r--packages/qte/qte-4.0.0-snapshot/fix-sl5000driver.patch (renamed from packages/qte/qte-4.0.0-b1/fix-sl5000driver.patch)0
-rw-r--r--packages/qte/qte-4.0.0-snapshot/fix-vncdriver.patch (renamed from packages/qte/qte-4.0.0-b1/fix-vncdriver.patch)0
-rw-r--r--packages/qte/qte-4.0.0-snapshot/gcc34.patch (renamed from packages/qte/qte-4.0.0-b1/gcc34.patch)0
-rw-r--r--packages/qte/qte-4.0.0-snapshot/no-moc-no-uic-no-rcc.patch (renamed from packages/qte/qte-4.0.0-b1/no-moc-no-uic-no-rcc.patch)0
-rw-r--r--packages/qte/qte-4.0.0-snapshot/sharp_char.h (renamed from packages/qte/qte-4.0.0-b1/sharp_char.h)0
-rw-r--r--packages/qte/qte-4.0.0-snapshot/switches.h (renamed from packages/qte/qte-4.0.0-b1/switches.h)0
-rw-r--r--packages/qte/qte-4.0.0-snapshot/update-qtfontdir (renamed from packages/qte/qte-4.0.0-b1/update-qtfontdir)0
-rw-r--r--packages/qte/qte_4.0.0-b1.bb235
-rw-r--r--packages/qte/qte_4.0.0-snapshot.bb0
15 files changed, 26 insertions, 236 deletions
diff --git a/packages/opie-help-en/opie-help-en_1.1.8.bb b/packages/opie-help-en/opie-help-en_1.1.8.bb
index e69de29bb2..03855646e2 100644
--- a/packages/opie-help-en/opie-help-en_1.1.8.bb
+++ b/packages/opie-help-en/opie-help-en_1.1.8.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "Opie Help Packages - English"
+SECTION = "opie/help"
+PRIORITY = "optional"
+MAINTAINER = "Team Opie <opie@handhelds.org>"
+LICENSE = "GPL"
+
+TAG = "${@'v' + bb.data.getVar('PV',d,1).replace('.', '_')}"
+SRC_URI = "${HANDHELDS_CVS};tag=${TAG};module=opie/help/en/html "
+S = "${WORKDIR}/html"
+
+do_install() {
+ install -d ${D}${palmtopdir}/help/en/html/
+ install -m 0644 ${WORKDIR}/html/*.html ${D}${palmtopdir}/help/en/html/
+ for d in $(find . -type d | grep -v "CVS\|patch")
+ do
+ install -d ${D}${palmtopdir}/help/en/html/$d
+ install -m 0644 ${WORKDIR}/html/$d/*.html ${D}${palmtopdir}/help/en/html/$d/
+ done
+}
+
+python populate_packages_prepend () {
+ help_dir = bb.data.expand('${palmtopdir}/help/en/html/', d)
+
+ do_split_packages(d, help_dir, file_regex='^(.*)\.html$', output_pattern='opie-%s-help-en', description='Opie Help for %s - English', aux_files_pattern=help_dir + '%s/*')
+}
diff --git a/packages/opie-help-en/opie-help-en_cvs.bb b/packages/opie-help-en/opie-help-en_cvs.bb
index 1826c3325c..8d3b757981 100644
--- a/packages/opie-help-en/opie-help-en_cvs.bb
+++ b/packages/opie-help-en/opie-help-en_cvs.bb
@@ -11,7 +11,7 @@ S = "${WORKDIR}/html"
do_install() {
install -d ${D}${palmtopdir}/help/en/html/
install -m 0644 ${WORKDIR}/html/*.html ${D}${palmtopdir}/help/en/html/
- for d in $(find . -type d | grep -v CVS)
+ for d in $(find . -type d | grep -v "CVS\|patch")
do
install -d ${D}${palmtopdir}/help/en/html/$d
install -m 0644 ${WORKDIR}/html/$d/*.html ${D}${palmtopdir}/help/en/html/$d/
diff --git a/packages/qte/qte-4.0.0-b1/add-qatomic.patch b/packages/qte/qte-4.0.0-snapshot/add-qatomic.patch
index e69de29bb2..e69de29bb2 100644
--- a/packages/qte/qte-4.0.0-b1/add-qatomic.patch
+++ b/packages/qte/qte-4.0.0-snapshot/add-qatomic.patch
diff --git a/packages/qte/qte-4.0.0-b1/fix-mkspecs.patch b/packages/qte/qte-4.0.0-snapshot/fix-mkspecs.patch
index e69de29bb2..e69de29bb2 100644
--- a/packages/qte/qte-4.0.0-b1/fix-mkspecs.patch
+++ b/packages/qte/qte-4.0.0-snapshot/fix-mkspecs.patch
diff --git a/packages/qte/qte-4.0.0-b1/fix-qwidget.patch b/packages/qte/qte-4.0.0-snapshot/fix-qwidget.patch
index e69de29bb2..e69de29bb2 100644
--- a/packages/qte/qte-4.0.0-b1/fix-qwidget.patch
+++ b/packages/qte/qte-4.0.0-snapshot/fix-qwidget.patch
diff --git a/packages/qte/qte-4.0.0-b1/fix-qwsmanager.patch b/packages/qte/qte-4.0.0-snapshot/fix-qwsmanager.patch
index e69de29bb2..e69de29bb2 100644
--- a/packages/qte/qte-4.0.0-b1/fix-qwsmanager.patch
+++ b/packages/qte/qte-4.0.0-snapshot/fix-qwsmanager.patch
diff --git a/packages/qte/qte-4.0.0-b1/fix-sl5000driver.patch b/packages/qte/qte-4.0.0-snapshot/fix-sl5000driver.patch
index e69de29bb2..e69de29bb2 100644
--- a/packages/qte/qte-4.0.0-b1/fix-sl5000driver.patch
+++ b/packages/qte/qte-4.0.0-snapshot/fix-sl5000driver.patch
diff --git a/packages/qte/qte-4.0.0-b1/fix-vncdriver.patch b/packages/qte/qte-4.0.0-snapshot/fix-vncdriver.patch
index e69de29bb2..e69de29bb2 100644
--- a/packages/qte/qte-4.0.0-b1/fix-vncdriver.patch
+++ b/packages/qte/qte-4.0.0-snapshot/fix-vncdriver.patch
diff --git a/packages/qte/qte-4.0.0-b1/gcc34.patch b/packages/qte/qte-4.0.0-snapshot/gcc34.patch
index e69de29bb2..e69de29bb2 100644
--- a/packages/qte/qte-4.0.0-b1/gcc34.patch
+++ b/packages/qte/qte-4.0.0-snapshot/gcc34.patch
diff --git a/packages/qte/qte-4.0.0-b1/no-moc-no-uic-no-rcc.patch b/packages/qte/qte-4.0.0-snapshot/no-moc-no-uic-no-rcc.patch
index e69de29bb2..e69de29bb2 100644
--- a/packages/qte/qte-4.0.0-b1/no-moc-no-uic-no-rcc.patch
+++ b/packages/qte/qte-4.0.0-snapshot/no-moc-no-uic-no-rcc.patch
diff --git a/packages/qte/qte-4.0.0-b1/sharp_char.h b/packages/qte/qte-4.0.0-snapshot/sharp_char.h
index e69de29bb2..e69de29bb2 100644
--- a/packages/qte/qte-4.0.0-b1/sharp_char.h
+++ b/packages/qte/qte-4.0.0-snapshot/sharp_char.h
diff --git a/packages/qte/qte-4.0.0-b1/switches.h b/packages/qte/qte-4.0.0-snapshot/switches.h
index e69de29bb2..e69de29bb2 100644
--- a/packages/qte/qte-4.0.0-b1/switches.h
+++ b/packages/qte/qte-4.0.0-snapshot/switches.h
diff --git a/packages/qte/qte-4.0.0-b1/update-qtfontdir b/packages/qte/qte-4.0.0-snapshot/update-qtfontdir
index e69de29bb2..e69de29bb2 100644
--- a/packages/qte/qte-4.0.0-b1/update-qtfontdir
+++ b/packages/qte/qte-4.0.0-snapshot/update-qtfontdir
diff --git a/packages/qte/qte_4.0.0-b1.bb b/packages/qte/qte_4.0.0-b1.bb
deleted file mode 100644
index 6c1936adf8..0000000000
--- a/packages/qte/qte_4.0.0-b1.bb
+++ /dev/null
@@ -1,235 +0,0 @@
-DESCRIPTION = "Qt/Embedded version ${PV}"
-SECTION = "libs"
-PRIORITY = "optional"
-LICENSE = "GPL QPL"
-DEPENDS = "zlib libpng jpeg tslib qmake-1.08a uicmoc4-native"
-PROVIDES = "virtual/qte4 virtual/libqte4"
-MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
-PR = "ml5"
-
-SRC_URI = "ftp://ftp.trolltech.com/pub/qt/source/qt-embedded-opensource-${PV}.tar.bz2 \
- file://gcc34.patch;patch=1 \
- file://add-qatomic.patch;patch=1 \
- file://fix-mkspecs.patch;patch=1 \
- file://fix-qwidget.patch;patch=1 \
- file://fix-qwsmanager.patch;patch=1 \
- file://fix-vncdriver.patch;patch=1 \
- file://fix-sl5000driver.patch;patch=1 \
- file://no-moc-no-uic-no-rcc.patch;patch=1 \
- file://sharp_char.h \
- file://switches.h \
- file://update-qtfontdir"
-S = "${WORKDIR}/qt-embedded-opensource-${PV}"
-
-DEFAULT_PREFERENCE = "-1"
-
-export QTDIR = "${S}"
-
-def qte_arch(d):
- import bb, re
- arch = bb.data.getVar('TARGET_ARCH', d, 1)
- if re.match("^i.86$", arch):
- arch = "x86"
- elif arch == "x86_64":
- arch = "x86"
- elif arch == "mipsel":
- arch = "mips"
- return arch
-
-QTE_ARCH := "${@qte_arch(d)}"
-
-#
-# How to build the embedded drivers. Use plugin-<type> or qt-<type>. As for Beta1, that doesn't work :D
-#
-GFX = "qt-gfx"
-KBD = "qt-kbd"
-MSE = "qt-mouse"
-
-#
-# Borken: yopy, busmouse, linuxtp
-#
-
-EXTRA_OECONF = "-embedded ${QTE_ARCH} \
- -system-libjpeg -system-libpng -system-zlib \
- -no-qvfb -no-nis -no-cups -no-stl -no-pch \
- -no-accessibility -no-compat \
- -qconfig large -depths 8,16,24,32 -fast \
- -qt-gfx-transformed \
- -qt-gfx-vnc \
- -${KBD}-sl5000 \
- -${KBD}-tty \
- -${KBD}-usb \
- -${MSE}-pc \
- "
-
-EXTRA_OEMAKE = "-e"
-PARALLEL_MAKE = ""
-
-export EXTRA_CFLAGS = "-I${STAGING_INCDIR}"
-export EXTRA_CXXFLAGS = "-I${STAGING_INCDIR}"
-export EXTRA_LFLAGS = "-L${STAGING_LIBDIR} -Wl,-rpath-link,${STAGING_LIBDIR}"
-
-do_configure() {
- unset QMAKESPEC
- echo yes | ./configure ${EXTRA_OECONF} || die "Configuring qt failed. EXTRA_OECONF was ${EXTRA_OECONF}"
-}
-
-do_compile() {
- unset CC LD CCLD CXX RANLIB AR STRIP CFLAGS LDFLAGS CXXFLAGS CPPFLAGS LINK
- install -m 0755 ${STAGING_BINDIR}/rcc4 ${S}/bin/rcc
- install -m 0755 ${STAGING_BINDIR}/moc4 ${S}/bin/moc
- install -m 0755 ${STAGING_BINDIR}/uic4 ${S}/bin/uic
-
- install -d include/asm/
- install -m 0644 ${WORKDIR}/sharp_char.h include/asm/
- install -d include/linux/
- install -m 0644 ${WORKDIR}/switches.h include/linux/
-
- oe_runmake
-}
-
-do_stage() {
- install -d ${STAGING_DIR}/${HOST_SYS}/qt4/lib
-
- for lib in Core Gui Network Sql Xml
- do
- cp -a lib/libQt${lib}* ${STAGING_DIR}/${HOST_SYS}/qt4/lib/
- done
-
- install -d ${STAGING_DIR}/${HOST_SYS}/qt4/include/
- cp -a include/* ${STAGING_DIR}/${HOST_SYS}/qt4/include
-}
-
-do_install() {
- install -d ${D}/${palmtopdir}/bin
- install -d ${D}/${sbindir}/
- install -m 0755 ${WORKDIR}/update-qtfontdir ${D}/${sbindir}/
- install -d ${D}${palmtopdir}/lib/fonts/
- cp -a lib/fonts/* ${D}${palmtopdir}/lib/fonts/
-
- for lib in Core Gui Network Sql Xml
- do
- oe_soinstall lib/libQt${lib}.so.4.0.0 ${D}/${palmtopdir}/lib
- done
-
- for i in `find . -perm 0755 -type f`
- do
- install -m 0755 $i ${D}/${palmtopdir}/bin/`basename $i`
- done
-}
-
-pkg_postinst() {
-#!/bin/sh
-if [ -n "$D" ]; then exit 1; fi
-set -e
-. /etc/profile
-${sbindir}/update-qtfontdir
-}
-
-pkg_postinst_qte-font-unicode() {
-#!/bin/sh
-if [ -n "$D" ]; then exit 1; fi
-set -e
-. /etc/profile
-${sbindir}/update-qtfontdir
-}
-
-pkg_postinst_qte-font-lcd () {
-#!/bin/sh
-if [ -n "$D" ]; then exit 1; fi
-set -e
-. /etc/profile
-${sbindir}/update-qtfontdir
-}
-
-pkg_postinst_qte-font-japanese() {
-#!/bin/sh
-if [ -n "$D" ]; then exit 1; fi
-set -e
-. /etc/profile
-${sbindir}/update-qtfontdir
-}
-
-pkg_postinst_qte-font-micro() {
-#!/bin/sh
-if [ -n "$D" ]; then exit 1; fi
-set -e
-. /etc/profile
-${sbindir}/update-qtfontdir
-}
-
-pkg_postinst_qte-font-courier() {
-#!/bin/sh
-if [ -n "$D" ]; then exit 1; fi
-set -e
-. /etc/profile
-${sbindir}/update-qtfontdir
-}
-
-LIB_PACKAGES = "\
- libqte4-debug \
- libqte4-core \
- libqte4-gui \
- libqte4-network \
- libqte4-sql \
- libqte4-xml \
- "
-
-
-FONT_PACKAGES = "\
- qte-font-fixed \
- qte-font-helvetica-small \
- qte-font-helvetica-large \
- qte-font-smoothtimes \
- qte-font-smallsmooth \
- qte-font-unicode \
- qte-font-lcd \
- qte-font-japanese \
- qte-font-micro \
- qte-font-courier \
- "
-
-PACKAGES = "${LIB_PACKAGES} ${FONT_PACKAGES} examples"
-
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
-FILES_${PN} = ""
-FILES_libqte4-debug = "${palmtopdir}/lib/libQt*_debug.*"
-FILES_libqte4-core = "${palmtopdir}/lib/libQtCore.* /usr/sbin/update-qtfontdir"
-FILES_libqte4-gui = "${palmtopdir}/lib/libQtGui.*"
-FILES_libqte4-network = "${palmtopdir}/lib/libQtNetwork.*"
-FILES_libqte4-sql = "${palmtopdir}/lib/libQtSql.*"
-FILES_libqte4-xml = "${palmtopdir}/lib/libQtXml.*"
-FILES_examples = "${palmtopdir}/bin"
-
-FILES_qte-font-fixed = "${palmtopdir}/lib/fonts/fixed*"
-PACKAGE_ARCH_qte-font-fixed = "all"
-
-FILES_qte-font-helvetica-small = "${palmtopdir}/lib/fonts/helvetica_80*.qpf \
- ${palmtopdir}/lib/fonts/helvetica_100*.qpf ${palmtopdir}/lib/fonts/helvetica_120*.qpf"
-PACKAGE_ARCH_qte-font-helvetica-small = "all"
-
-FILES_qte-font-helvetica-large = "${palmtopdir}/lib/fonts/helvetica_140*.qpf \
- ${palmtopdir}/lib/fonts/helvetica_180*.qpf ${palmtopdir}/lib/fonts/helvetica_240*.qpf"
-PACKAGE_ARCH_qte-font-helvetica-large = "all"
-
-FILES_qte-font-smoothtimes = "${palmtopdir}/lib/fonts/smoothtimes*"
-PACKAGE_ARCH_qte-font-smoothtimes = "all"
-
-FILES_qte-font-smallsmooth = "${palmtopdir}/lib/fonts/smallsmooth*"
-PACKAGE_ARCH_qte-font-smallsmooth = "all"
-
-FILES_qte-font-unicode = "${palmtopdir}/lib/fonts/unifont*.qpf"
-PACKAGE_ARCH_qte-font-unicode = "all"
-
-FILES_qte-font-lcd = "${palmtopdir}/lib/fonts/lcd*"
-PACKAGE_ARCH_qte-font-lcd = "all"
-
-FILES_qte-font-japanese = "${palmtopdir}/lib/fonts/japanese*"
-PACKAGE_ARCH_qte-font-japanese = "all"
-
-FILES_qte-font-micro = "${palmtopdir}/lib/fonts/micro*.qpf"
-PACKAGE_ARCH_qte-font-micro = "all"
-
-FILES_qte-font-courier = "${palmtopdir}/lib/fonts/cour*"
-PACKAGE_ARCH_qte-font-courier = "all"
diff --git a/packages/qte/qte_4.0.0-snapshot.bb b/packages/qte/qte_4.0.0-snapshot.bb
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/qte/qte_4.0.0-snapshot.bb