aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2009-11-13 19:22:46 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2009-11-13 19:25:51 +0100
commit2bf3d3e7c254ec2a2c52ffe8b8a88cf4ea595372 (patch)
treee363cc2d7a86a65056985bf3d92928dfdab63cfc
parent6901f1acf34e3577f902228448dec2f6944ff924 (diff)
downloadopenembedded-2bf3d3e7c254ec2a2c52ffe8b8a88cf4ea595372.tar.gz
update-alternatives-cworth: fix link&directory check, add virtual to task-boot to build it before any image
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes/tasks/task-boot.bb2
-rw-r--r--recipes/update-alternatives/update-alternatives-cworth.inc2
-rw-r--r--recipes/update-alternatives/update-alternatives-cworth/update-alternatives.use.last.patch2
3 files changed, 3 insertions, 3 deletions
diff --git a/recipes/tasks/task-boot.bb b/recipes/tasks/task-boot.bb
index 1a1b9f25c8..bdba970998 100644
--- a/recipes/tasks/task-boot.bb
+++ b/recipes/tasks/task-boot.bb
@@ -14,7 +14,7 @@ MACHINE_ESSENTIAL_EXTRA_RDEPENDS ?= ""
MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS ?= ""
# Make sure we build the kernel
-DEPENDS = "virtual/kernel"
+DEPENDS = "virtual/kernel virtual/update-alternatives-native"
#
# minimal set of packages - needed to boot
diff --git a/recipes/update-alternatives/update-alternatives-cworth.inc b/recipes/update-alternatives/update-alternatives-cworth.inc
index 3c1b2e62cf..e53e9ddec2 100644
--- a/recipes/update-alternatives/update-alternatives-cworth.inc
+++ b/recipes/update-alternatives/update-alternatives-cworth.inc
@@ -5,4 +5,4 @@ SRC_URI = "${HANDHELDS_CVS};module=familiar/dist/ipkg;tag=${@'V' + bb.data.getVa
S = "${WORKDIR}/ipkg/C"
PACKAGE_ARCH = "all"
-PR = "r1"
+PR = "r2"
diff --git a/recipes/update-alternatives/update-alternatives-cworth/update-alternatives.use.last.patch b/recipes/update-alternatives/update-alternatives-cworth/update-alternatives.use.last.patch
index c23c4f8007..7bd5bd268b 100644
--- a/recipes/update-alternatives/update-alternatives-cworth/update-alternatives.use.last.patch
+++ b/recipes/update-alternatives/update-alternatives-cworth/update-alternatives.use.last.patch
@@ -24,7 +24,7 @@ diff -uNr C.orig/update-alternatives C/update-alternatives
if [ ! -d $link_dir ]; then
mkdir -p $link_dir
fi
-+ if [ -h $link ]; then
++ if [ -h $link -a -d $link ]; then
+ # if $link exists and the target is directory, than ln -sf $path $link, doesn't replace link to that directory, but creates new link inside
+ echo "update-alternatives: Removing $link"
+ rm -f $link