aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2009-11-18 13:04:46 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2009-11-18 13:06:50 +0100
commit23a14b0204a1f171b973159d3a9e9246b7fca86e (patch)
tree0006f705a4bf8c46ef9a98522943b5ca5345723d
parent8efd69c0dec4ee8d152c0d17b9b513dc7fc88e06 (diff)
downloadopenembedded-23a14b0204a1f171b973159d3a9e9246b7fca86e.tar.gz
sync with oe.dev
* remove dbus_1.2.14, python-pygtk_2.16.0 as it isn't used/tested in shr * add qwo_0.4 and resolvconf_1.43 because it exists in oe.dev and there are strict rules for removing stuff
-rw-r--r--recipes/dbus/dbus-1.2.14/0001-Make-the-default-DBus-reply-timeout-configurable.patch78
-rw-r--r--recipes/dbus/dbus-1.2.14/0002-Fix-Pending-Connections-Bug.patch99
-rw-r--r--recipes/dbus/dbus-1.2.14/cross.patch10
-rw-r--r--recipes/dbus/dbus-1.2.14/dbus-1.init111
-rw-r--r--recipes/dbus/dbus-1.2.14/fix-install-daemon.patch13
-rw-r--r--recipes/dbus/dbus-1.2.14/permissive.patch11
-rw-r--r--recipes/dbus/dbus-1.2.14/tmpdir.patch30
-rw-r--r--recipes/dbus/dbus_1.2.14.bb5
-rw-r--r--recipes/glibc/files/armv4t-interworking.patch2
-rw-r--r--recipes/linux/linux-openmoko.inc6
-rw-r--r--recipes/mesa/mesa-dri_6.5.2.bb3
-rw-r--r--recipes/mesa/mesa-dri_7.0.3.bb3
-rw-r--r--recipes/python/python-pygtk/nodocs-2.16.0.patch13
-rw-r--r--recipes/python/python-pygtk_2.16.0.bb64
-rw-r--r--recipes/qwo/qwo-0.4/check_lib.patch20
-rw-r--r--recipes/qwo/qwo_0.4.bb16
-rw-r--r--recipes/resolvconf/resolvconf_1.43.bb29
-rw-r--r--recipes/xorg-driver/files/0001-dpms.h-dpmsconst.h.patch25
-rw-r--r--recipes/xorg-driver/xf86-video-glamo_git.bb1
19 files changed, 73 insertions, 466 deletions
diff --git a/recipes/dbus/dbus-1.2.14/0001-Make-the-default-DBus-reply-timeout-configurable.patch b/recipes/dbus/dbus-1.2.14/0001-Make-the-default-DBus-reply-timeout-configurable.patch
deleted file mode 100644
index a38e3db0de..0000000000
--- a/recipes/dbus/dbus-1.2.14/0001-Make-the-default-DBus-reply-timeout-configurable.patch
+++ /dev/null
@@ -1,78 +0,0 @@
-From fb546488e93a1638d377b228bbb0d2ab58462168 Mon Sep 17 00:00:00 2001
-From: Daniel Willmann <daniel@totalueberwachung.de>
-Date: Thu, 2 Oct 2008 15:50:17 +0800
-Subject: [PATCH] Make the default DBus reply timeout configurable
-
-This patch adds an option --with-dbus-default-reply-timeout to configure
-that will set the default reply timeout used by libdbus in milliseconds.
-autoconf and autoheader need to be rerun in order to regenerate the
-correct configure and config.h.in files.
----
- configure.in | 9 +++++++++
- dbus/dbus-connection-internal.h | 3 ---
- dbus/dbus-pending-call.c | 1 +
- 3 files changed, 10 insertions(+), 3 deletions(-)
-
-diff --git a/configure.in b/configure.in
-index 62ac387..5c912d7 100644
---- a/configure.in
-+++ b/configure.in
-@@ -88,6 +88,7 @@ AC_ARG_WITH(console-auth-dir, AS_HELP_STRING([--with-console-auth-dir=[dirname]]
- AC_ARG_WITH(console-owner-file, AS_HELP_STRING([--with-console-owner-file=[filename]],[file whose owner determines current console owner]))
- AC_ARG_WITH(dbus_user, AS_HELP_STRING([--with-dbus-user=<user>],[User for running the DBUS daemon (messagebus)]))
- AC_ARG_WITH(dbus_daemondir, AS_HELP_STRING([--with-dbus-daemondir=[dirname]],[Directory for installing the DBUS daemon]))
-+AC_ARG_WITH(dbus_default_reply_timeout, AS_HELP_STRING([--with-dbus-default-reply-timeout=[milliseconds]],[Default reply timeout for DBus method calls]))
-
- AC_DEFINE(DBUS_UNIX,1,[dbus on unix])
-
-@@ -986,6 +987,13 @@ if test x$have_libaudit = xyes ; then
- AC_DEFINE(HAVE_LIBAUDIT,1,[audit daemon SELinux support])
- fi
-
-+if test -z "$with_dbus_default_reply_timeout" ; then
-+ DBUS_DEFAULT_REPLY_TIMEOUT=25000
-+else
-+ DBUS_DEFAULT_REPLY_TIMEOUT=$with_dbus_default_reply_timeout
-+fi
-+AC_DEFINE_UNQUOTED(_DBUS_DEFAULT_TIMEOUT_VALUE,$DBUS_DEFAULT_REPLY_TIMEOUT,[default timeout value for dbus calls])
-+
- #### Set up final flags
- DBUS_CLIENT_CFLAGS=
- DBUS_CLIENT_LIBS="$THREAD_LIBS"
-@@ -1348,6 +1356,7 @@ echo "
- Gettext libs (empty OK): ${INTLLIBS}
- Using XML parser: ${with_xml}
- Init scripts style: ${with_init_scripts}
-+ Default reply timeout: ${DBUS_DEFAULT_REPLY_TIMEOUT}
- Abstract socket names: ${ac_cv_have_abstract_sockets}
- System bus socket: ${DBUS_SYSTEM_SOCKET}
- System bus address: ${DBUS_SYSTEM_BUS_DEFAULT_ADDRESS}
-diff --git a/dbus/dbus-connection-internal.h b/dbus/dbus-connection-internal.h
-index df54412..5fe536b 100644
---- a/dbus/dbus-connection-internal.h
-+++ b/dbus/dbus-connection-internal.h
-@@ -41,9 +41,6 @@ typedef enum
- DBUS_ITERATION_BLOCK = 1 << 2 /**< Block if nothing to do. */
- } DBusIterationFlags;
-
--/** default timeout value when waiting for a message reply, 25 seconds */
--#define _DBUS_DEFAULT_TIMEOUT_VALUE (25 * 1000)
--
- void _dbus_connection_lock (DBusConnection *connection);
- void _dbus_connection_unlock (DBusConnection *connection);
- DBusConnection * _dbus_connection_ref_unlocked (DBusConnection *connection);
-diff --git a/dbus/dbus-pending-call.c b/dbus/dbus-pending-call.c
-index 51b9378..5a7a5f4 100644
---- a/dbus/dbus-pending-call.c
-+++ b/dbus/dbus-pending-call.c
-@@ -21,6 +21,7 @@
- *
- */
-
-+#include <config.h>
- #include "dbus-internals.h"
- #include "dbus-connection-internal.h"
- #include "dbus-pending-call-internal.h"
---
-1.5.6.4
-
diff --git a/recipes/dbus/dbus-1.2.14/0002-Fix-Pending-Connections-Bug.patch b/recipes/dbus/dbus-1.2.14/0002-Fix-Pending-Connections-Bug.patch
deleted file mode 100644
index 11cb14d7c2..0000000000
--- a/recipes/dbus/dbus-1.2.14/0002-Fix-Pending-Connections-Bug.patch
+++ /dev/null
@@ -1,99 +0,0 @@
-diff -Naur --exclude '*.swp' dbus-1.2.14.orig/dbus/dbus-connection.c dbus-1.2.14.bug-19796-v2/dbus/dbus-connection.c
---- dbus-1.2.14.orig/dbus/dbus-connection.c 2009-05-06 17:51:18.000000000 +0100
-+++ dbus-1.2.14.bug-19796-v2/dbus/dbus-connection.c 2009-06-04 18:04:51.000000000 +0100
-@@ -3167,12 +3167,25 @@
- * @returns #FALSE if no memory, #TRUE otherwise.
- *
- */
-+
-+DBUS_DEPRECATED
- dbus_bool_t
- dbus_connection_send_with_reply (DBusConnection *connection,
- DBusMessage *message,
- DBusPendingCall **pending_return,
- int timeout_milliseconds)
- {
-+ return dbus_connection_send_with_reply_setup (connection, message, pending_return, NULL, NULL, timeout_milliseconds);
-+}
-+
-+dbus_bool_t
-+dbus_connection_send_with_reply_setup (DBusConnection *connection,
-+ DBusMessage *message,
-+ DBusPendingCall **pending_return,
-+ DBusPendingCallSetup pending_setup,
-+ void *setup_user_data,
-+ int timeout_milliseconds)
-+{
- DBusPendingCall *pending;
- dbus_int32_t serial = -1;
- DBusDispatchStatus status;
-@@ -3181,6 +3194,11 @@
- _dbus_return_val_if_fail (message != NULL, FALSE);
- _dbus_return_val_if_fail (timeout_milliseconds >= 0 || timeout_milliseconds == -1, FALSE);
-
-+ if (pending_return && (!pending_setup))
-+ {
-+ _dbus_warn ("Using **pending_return in dbus_connection_send_with_reply_setup() without pending_setup is deprecated and strongly discouraged\n");
-+ }
-+
- if (pending_return)
- *pending_return = NULL;
-
-@@ -3189,7 +3207,6 @@
- if (!_dbus_connection_get_is_connected_unlocked (connection))
- {
- CONNECTION_UNLOCK (connection);
--
- return TRUE;
- }
-
-@@ -3222,6 +3239,9 @@
- pending))
- goto error;
-
-+ if (pending_setup)
-+ pending_setup(pending, setup_user_data);
-+
- if (!_dbus_connection_send_unlocked_no_update (connection, message, NULL))
- {
- _dbus_connection_detach_pending_call_and_unlock (connection,
-@@ -3300,8 +3320,8 @@
- _dbus_return_val_if_fail (timeout_milliseconds >= 0 || timeout_milliseconds == -1, NULL);
- _dbus_return_val_if_error_is_set (error, NULL);
-
-- if (!dbus_connection_send_with_reply (connection, message,
-- &pending, timeout_milliseconds))
-+ if (!dbus_connection_send_with_reply_setup (connection, message,
-+ &pending, NULL, NULL, timeout_milliseconds))
- {
- _DBUS_SET_OOM (error);
- return NULL;
-diff -Naur --exclude '*.swp' dbus-1.2.14.orig/dbus/dbus-connection.h dbus-1.2.14.bug-19796-v2/dbus/dbus-connection.h
---- dbus-1.2.14.orig/dbus/dbus-connection.h 2009-04-17 20:45:29.000000000 +0100
-+++ dbus-1.2.14.bug-19796-v2/dbus/dbus-connection.h 2009-06-04 17:45:02.000000000 +0100
-@@ -47,6 +47,7 @@
- typedef struct DBusPreallocatedSend DBusPreallocatedSend;
- /** Opaque type representing a method call that has not yet received a reply. */
- typedef struct DBusPendingCall DBusPendingCall;
-+typedef void (*DBusPendingCallSetup)(DBusPendingCall *pending, void *user_data);
- /** Opaque type representing a connection to a remote application and associated incoming/outgoing message queues. */
- typedef struct DBusConnection DBusConnection;
- /** Set of functions that must be implemented to handle messages sent to a particular object path. */
-@@ -199,10 +200,17 @@
- dbus_bool_t dbus_connection_send (DBusConnection *connection,
- DBusMessage *message,
- dbus_uint32_t *client_serial);
-+DBUS_DEPRECATED
- dbus_bool_t dbus_connection_send_with_reply (DBusConnection *connection,
- DBusMessage *message,
- DBusPendingCall **pending_return,
- int timeout_milliseconds);
-+dbus_bool_t dbus_connection_send_with_reply_setup (DBusConnection *connection,
-+ DBusMessage *message,
-+ DBusPendingCall **pending_return,
-+ DBusPendingCallSetup pending_setup,
-+ void *setup_user_data,
-+ int timeout_milliseconds);
- DBusMessage * dbus_connection_send_with_reply_and_block (DBusConnection *connection,
- DBusMessage *message,
- int timeout_milliseconds,
diff --git a/recipes/dbus/dbus-1.2.14/cross.patch b/recipes/dbus/dbus-1.2.14/cross.patch
deleted file mode 100644
index 268a3ae3de..0000000000
--- a/recipes/dbus/dbus-1.2.14/cross.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- /tmp/configure.in 2006-11-09 21:47:10.000000000 +0100
-+++ dbus-0.95/configure.in 2006-11-09 21:48:13.108554000 +0100
-@@ -719,6 +719,7 @@
- exit (0);
- ]])],
- [ac_cv_have_abstract_sockets=yes],
-+ [ac_cv_have_abstract_sockets=no],
- [ac_cv_have_abstract_sockets=no]
- )])
- AC_LANG_POP(C)
diff --git a/recipes/dbus/dbus-1.2.14/dbus-1.init b/recipes/dbus/dbus-1.2.14/dbus-1.init
deleted file mode 100644
index a70e7a2373..0000000000
--- a/recipes/dbus/dbus-1.2.14/dbus-1.init
+++ /dev/null
@@ -1,111 +0,0 @@
-#! /bin/sh
-# -*- coding: utf-8 -*-
-# Debian init.d script for D-BUS
-# Copyright © 2003 Colin Walters <walters@debian.org>
-# Copyright 2008 OE Team
-
-set -e
-
-DAEMON=/usr/bin/dbus-daemon
-NAME=dbus
-DAEMONUSER=messagebus
-RUNDIR=/var/run/dbus
-PIDFILE=/var/run/dbus/pid
-UUIDDIR=/var/lib/dbus
-DESC="system message bus"
-EVENTDIR=/etc/dbus-1/event.d
-
-test -x $DAEMON || exit 0
-
-# Source defaults file; edit that file to configure this script.
-ENABLED=1
-PARAMS=""
-if [ -e /etc/default/dbus ]; then
- . /etc/default/dbus
-fi
-
-test "$ENABLED" != "0" || exit 0
-
-start_it_up()
-{
- if [ ! -d $RUNDIR ]; then
- mkdir -p $RUNDIR
- chown $DAEMONUSER $RUNDIR
- chgrp $DAEMONUSER $RUNDIR
- fi
- if [ -e $PIDFILE ]; then
- PIDDIR=/proc/$(cat $PIDFILE)
- if [ -d ${PIDDIR} -a "$(readlink -f ${PIDDIR}/exe)" = "${DAEMON}" ]; then
- echo "$DESC already started; not starting."
- else
- echo "Removing stale PID file $PIDFILE."
- rm -f $PIDFILE
- fi
- fi
-
- if [ ! -d $UUIDDIR ]; then
- mkdir -p $UUIDDIR
- chown $DAEMONUSER $UUIDDIR
- chgrp $DAEMONUSER $UUIDDIR
- fi
-
- dbus-uuidgen --ensure
-
- echo -n "Starting $DESC: "
- start-stop-daemon --start --pidfile $PIDFILE \
- --user $DAEMONUSER --exec $DAEMON -- --system $PARAMS
- echo "$NAME."
- if [ -d $EVENTDIR ]; then
- run-parts --arg=start $EVENTDIR
- fi
-}
-
-shut_it_down()
-{
- if [ -d $EVENTDIR ]; then
- # TODO: --reverse when busybox supports it
- run-parts --arg=stop $EVENTDIR
- fi
- echo -n "Stopping $DESC: "
- start-stop-daemon --stop --oknodo --pidfile $PIDFILE \
- --user $DAEMONUSER
- # We no longer include these arguments so that start-stop-daemon
- # can do its job even given that we may have been upgraded.
- # We rely on the pidfile being sanely managed
- # --exec $DAEMON -- --system $PARAMS
- echo "$NAME."
- rm -f $PIDFILE
-}
-
-reload_it()
-{
- echo -n "Reloading $DESC config: "
- dbus-send --print-reply --system --type=method_call \
- --dest=org.freedesktop.DBus \
- / org.freedesktop.DBus.ReloadConfig > /dev/null
- # hopefully this is enough time for dbus to reload it's config file.
- echo "done."
-}
-
-case "$1" in
- start)
- start_it_up
- ;;
- stop)
- shut_it_down
- ;;
- reload|force-reload)
- reload_it
- ;;
- restart)
- shut_it_down
- sleep 1
- start_it_up
- ;;
- *)
- echo "Usage: /etc/init.d/$NAME {start|stop|restart|reload|force-reload}" >&2
- exit 1
- ;;
-esac
-
-exit 0
diff --git a/recipes/dbus/dbus-1.2.14/fix-install-daemon.patch b/recipes/dbus/dbus-1.2.14/fix-install-daemon.patch
deleted file mode 100644
index c31786357d..0000000000
--- a/recipes/dbus/dbus-1.2.14/fix-install-daemon.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: dbus-0.94/bus/Makefile.am
-===================================================================
---- dbus-0.94.orig/bus/Makefile.am 2006-10-01 17:36:18.000000000 +0200
-+++ dbus-0.94/bus/Makefile.am 2006-10-14 21:40:05.000000000 +0200
-@@ -110,7 +110,7 @@
- $(mkinstalldirs) $(DESTDIR)$(DBUS_DAEMONDIR); \
- chmod 755 $(DESTDIR)$(DBUS_DAEMONDIR); \
- fi
-- $(INSTALL_PROGRAM) dbus-daemon $(DESTDIR)$(DBUS_DAEMONDIR)
-+ $(INSTALL_PROGRAM) .libs/dbus-daemon $(DESTDIR)$(DBUS_DAEMONDIR)
- $(mkinstalldirs) $(DESTDIR)$(localstatedir)/run/dbus
- $(mkinstalldirs) $(DESTDIR)$(configdir)/system.d
- $(mkinstalldirs) $(DESTDIR)$(datadir)/dbus-1/services
diff --git a/recipes/dbus/dbus-1.2.14/permissive.patch b/recipes/dbus/dbus-1.2.14/permissive.patch
deleted file mode 100644
index c8d17e06f7..0000000000
--- a/recipes/dbus/dbus-1.2.14/permissive.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- /usr/src/openmoko/unstable-build/work/armv4t-angstrom-linux-gnueabi/dbus-1.2.14-r1/dbus-1.2.14/bus/system.conf.in 2009-05-06 10:19:43.000000000 -0600
-+++ dbus-1.2.4.6/bus/system.conf.in 2009-05-06 11:26:47.000000000 -0600
-@@ -48,7 +48,7 @@
- <!-- Holes must be punched in service configuration files for
- name ownership and sending method calls -->
- <deny own="*"/>
-- <deny send_type="method_call"/>
-+ <allow send_type="method_call" log="true"/>
-
- <!-- Signals and reply messages (method returns, errors) are allowed
- by default -->
diff --git a/recipes/dbus/dbus-1.2.14/tmpdir.patch b/recipes/dbus/dbus-1.2.14/tmpdir.patch
deleted file mode 100644
index 838b903f0a..0000000000
--- a/recipes/dbus/dbus-1.2.14/tmpdir.patch
+++ /dev/null
@@ -1,30 +0,0 @@
---- dbus-0.22/configure.in.orig 2004-08-13 00:57:16.000000000 +0200
-+++ dbus-0.22/configure.in 2004-12-30 21:15:57.000000000 +0100
-@@ -1047,15 +1048,18 @@
- AC_SUBST(ABSOLUTE_TOP_BUILDDIR)
-
- #### Find socket directories
--if ! test -z "$TMPDIR" ; then
-- DEFAULT_SOCKET_DIR=$TMPDIR
--elif ! test -z "$TEMP" ; then
-- DEFAULT_SOCKET_DIR=$TEMP
--elif ! test -z "$TMP" ; then
-- DEFAULT_SOCKET_DIR=$TMP
--else
-- DEFAULT_SOCKET_DIR=/tmp
--fi
-+#if ! test -z "$TMPDIR" ; then
-+# DEFAULT_SOCKET_DIR=$TMPDIR
-+#elif ! test -z "$TEMP" ; then
-+# DEFAULT_SOCKET_DIR=$TEMP
-+#elif ! test -z "$TMP" ; then
-+# DEFAULT_SOCKET_DIR=$TMP
-+#else
-+# DEFAULT_SOCKET_DIR=/tmp
-+#fi
-+
-+# checks disabled to avoid expanding this at build time
-+DEFAULT_SOCKET_DIR=/tmp
-
- if ! test -z "$with_test_socket_dir" ; then
- TEST_SOCKET_DIR="$with_test_socket_dir"
diff --git a/recipes/dbus/dbus_1.2.14.bb b/recipes/dbus/dbus_1.2.14.bb
deleted file mode 100644
index dfed3de93d..0000000000
--- a/recipes/dbus/dbus_1.2.14.bb
+++ /dev/null
@@ -1,5 +0,0 @@
-include dbus.inc
-SRC_URI += "file://0002-Fix-Pending-Connections-Bug.patch;patch=1 \
- file://permissive.patch;patch=1"
-
-PR = "${INC_PR}.2"
diff --git a/recipes/glibc/files/armv4t-interworking.patch b/recipes/glibc/files/armv4t-interworking.patch
index 5493e0516c..ce91ad6530 100644
--- a/recipes/glibc/files/armv4t-interworking.patch
+++ b/recipes/glibc/files/armv4t-interworking.patch
@@ -34,7 +34,7 @@
#endif
@ pick the function arg and call address off the stack and execute
ldr r0, [sp, #4]
-+#if defined(__ARM_ARCH_4T__) && defined(__THUMB_INTERWORK__)
++#if defined(__ARM_ARCH_V4T__) && defined(__THUMB_INTERWORK__)
+ ldr ip, [sp], #8
+ mov lr, pc
+ bx ip
diff --git a/recipes/linux/linux-openmoko.inc b/recipes/linux/linux-openmoko.inc
index 6fe3c0ee38..84a77ea586 100644
--- a/recipes/linux/linux-openmoko.inc
+++ b/recipes/linux/linux-openmoko.inc
@@ -28,6 +28,12 @@ THUMB_INTERWORKING = "no"
module_autoload_ohci-hcd = "ohci-hcd"
module_autoload_hci_usb = "hci_usb"
module_autoload_g_ether = "g_ether"
+# audio (GTA01)
+module_autoload_snd-soc-neo1973-wm8753 = "snd-soc-neo1973-wm8753"
+# audio (GTA02)
+module_autoload_snd-soc-neo1973-gta02-wm8753 = "snd-soc-neo1973-gta02-wm8753"
+# audio (GTA03)
+module_autoload_snd-soc-neo1973-gta02-wm8753 = ""
# sd/mmc
module_autoload_s3cmci = "s3cmci"
diff --git a/recipes/mesa/mesa-dri_6.5.2.bb b/recipes/mesa/mesa-dri_6.5.2.bb
index 28e27cdb4e..f94ea8b3d2 100644
--- a/recipes/mesa/mesa-dri_6.5.2.bb
+++ b/recipes/mesa/mesa-dri_6.5.2.bb
@@ -8,9 +8,6 @@ PACKAGES_DYNAMIC = "mesa-dri-driver-*"
PR = "r2"
-# most of our targets do not have DRI so will use mesa-xlib
-DEFAULT_PREFERENCE = "-1"
-
DEPENDS += "libdrm"
# DRI is useless without the kernel drivers
RRECOMMENDS += " kernel-module-drm kernel-module-radeon "
diff --git a/recipes/mesa/mesa-dri_7.0.3.bb b/recipes/mesa/mesa-dri_7.0.3.bb
index 25d78ccbd6..330efb23af 100644
--- a/recipes/mesa/mesa-dri_7.0.3.bb
+++ b/recipes/mesa/mesa-dri_7.0.3.bb
@@ -9,9 +9,6 @@ PACKAGES_DYNAMIC = "mesa-dri-driver-*"
PR = "r1"
-# most of our targets do not have DRI so will use mesa-xlib
-DEFAULT_PREFERENCE = "-1"
-
DEPENDS += "libdrm"
# DRI is useless without the kernel drivers
RRECOMMENDS += " kernel-module-drm kernel-module-radeon "
diff --git a/recipes/python/python-pygtk/nodocs-2.16.0.patch b/recipes/python/python-pygtk/nodocs-2.16.0.patch
deleted file mode 100644
index b19ae445ed..0000000000
--- a/recipes/python/python-pygtk/nodocs-2.16.0.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: pygtk-2.10.4/Makefile.am
-===================================================================
---- pygtk-2.10.4.orig/Makefile.am
-+++ pygtk-2.10.4/Makefile.am
-@@ -4,7 +4,7 @@ if BUILD_GTK
- GTK_SUBDIR = gtk
- endif
-
--SUBDIRS = . $(GTK_SUBDIR) examples tests docs
-+SUBDIRS = . $(GTK_SUBDIR) examples tests
-
- PLATFORM_VERSION = 2.0
-
diff --git a/recipes/python/python-pygtk_2.16.0.bb b/recipes/python/python-pygtk_2.16.0.bb
deleted file mode 100644
index 939d9bef33..0000000000
--- a/recipes/python/python-pygtk_2.16.0.bb
+++ /dev/null
@@ -1,64 +0,0 @@
-DESCRIPTION = "Python GTK+ 2.10.x Bindings"
-SECTION = "devel/python"
-# needs gtk+ 2.10.x
-DEPENDS = "gtk+ libglade python-pycairo python-pygobject"
-RDEPENDS = "python-shell python-pycairo python-pygobject"
-PROVIDES = "python-pygtk2"
-SRCNAME = "pygtk"
-LICENSE = "LGPL"
-PR = "ml0"
-
-MAJ_VER = "${@bb.data.getVar('PV',d,1).split('.')[0]}.${@bb.data.getVar('PV',d,1).split('.')[1]}"
-SRC_URI = "ftp://ftp.gnome.org/pub/gnome/sources/pygtk/${MAJ_VER}/${SRCNAME}-${PV}.tar.bz2 \
- file://fix-gtkunixprint.patch;patch=1 \
- file://prevent_to_get_display_during_import.patch;patch=1 \
- file://nodocs-2.16.0.patch;patch=1 \
- file://acinclude.m4"
-S = "${WORKDIR}/${SRCNAME}-${PV}"
-
-EXTRA_OECONF = "\
- --disable-docs \
- --with-python-includes=${STAGING_INCDIR}/../ \
-"
-
-inherit autotools pkgconfig distutils-base
-
-do_configure_prepend() {
- install -m 0644 ${WORKDIR}/acinclude.m4 ${S}/
-}
-
-# dirty fix #1: remove dependency on python-pygobject-dev
-do_install_append() {
- find ${D} -name "*.la"|xargs rm -f
- rm -f ${D}/${bindir}/pygtk-codegen-2.0
- rm -rf ${D}/${libdir}/pkgconfig
-}
-
-# dirty fix #2: fix build system paths leaking in
-require fix-path.inc
-
-PACKAGES =+ "${PN}-demo"
-FILES_${PN}-demo = "\
- ${bindir}/pygtk-demo \
- ${libdir}/pygtk \
-"
-RDEPENDS_${PN}-demo = "python-pygtk python-stringold python-lang"
-
-# todo: revamp packaging, package demo seperatly
-FILES_${PN}-dev += "\
- ${libdir}/pygtk/2.0 \
- ${bindir}/pygtk-* \
- ${datadir}/pygtk/2.0"
-
-do_stage() {
- autotools_stage_includes
-# sed -i s:/usr/share:${STAGING_DATADIR}: codegen/pygtk-codegen-2.0
-# install -m 0755 codegen/pygtk-codegen-2.0 ${STAGING_BINDIR_NATIVE}/
- # until we have a newer pygobject version, we resue pygtk's codegen
-# ln -sf ./pygtk-codegen-2.0 ${STAGING_BINDIR_NATIVE}/pygobject-codegen-2.0
- install -d ${STAGING_DATADIR}/pygtk/2.0/codegen
- install -d ${STAGING_DATADIR}/pygtk/2.0/defs/
-# cp -pPr codegen/*.py* ${STAGING_DATADIR}/pygtk/2.0/codegen/
- cp -pPr *.defs ${STAGING_DATADIR}/pygtk/2.0/defs/
- cp -pPr gtk/*.defs ${STAGING_DATADIR}/pygtk/2.0/defs/
-}
diff --git a/recipes/qwo/qwo-0.4/check_lib.patch b/recipes/qwo/qwo-0.4/check_lib.patch
new file mode 100644
index 0000000000..c22ec20312
--- /dev/null
+++ b/recipes/qwo/qwo-0.4/check_lib.patch
@@ -0,0 +1,20 @@
+diff --git a/configure.ac b/configure.ac
+index 8a66f96..61063a9 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -19,15 +19,7 @@ AC_CHECK_LIB(config, config_read)
+
+ dnl Check for imlib2 library
+
+-AC_PATH_PROG(IMLIB2_CONFIG, imlib2-config, no)
+-
+-if test "$IMLIB2_CONFIG" = "no" ; then
+- AC_MSG_ERROR([
+-*** Unable to find Imlib2 library.])
+-else
+- CFLAGS="$CFLAGS `$IMLIB2_CONFIG --cflags`"
+- LIBS="$LIBS `$IMLIB2_CONFIG --libs`"
+-fi
++AC_CHECK_LIB(Imlib2, imlib_create_image)
+
+ dnl Check for help2man
diff --git a/recipes/qwo/qwo_0.4.bb b/recipes/qwo/qwo_0.4.bb
new file mode 100644
index 0000000000..03ce7d6a88
--- /dev/null
+++ b/recipes/qwo/qwo_0.4.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "qwo virtual keyboard"
+AUTHOR = "Charles Clement"
+HOMEPAGE = "http://www.nongnu.org/qwo/"
+SECTION = "x11"
+PRIORITY = "optional"
+LICENSE = "GPLv2"
+DEPENDS = "libxtst libxext virtual/imlib2 libconfig"
+RDEPENDS += "imlib2-loaders"
+PV = "0.4"
+PR = "r0"
+
+SRC_URI = "http://download.savannah.nongnu.org/releases/qwo/qwo-${PV}.tar.gz \
+ file://check_lib.patch;patch=1 \
+ "
+
+inherit autotools
diff --git a/recipes/resolvconf/resolvconf_1.43.bb b/recipes/resolvconf/resolvconf_1.43.bb
new file mode 100644
index 0000000000..2c210ef1ec
--- /dev/null
+++ b/recipes/resolvconf/resolvconf_1.43.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "Resolvconf is a framework for keeping track of the system's \
+information about currently available nameservers. It sets \
+itself up as the intermediary between programs that supply \
+nameserver information and programs that need nameserver \
+information."
+SECTION = "console/network"
+LICENSE = "GPL"
+AUTHOR = "Thomas Hood"
+HOMEPAGE = "http://packages.debian.org/resolvconf"
+DEPENDS = "bash"
+RDEPENDS = "bash"
+
+SRC_URI = "${DEBIAN_MIRROR}/main/r/resolvconf/resolvconf_${PV}.tar.gz"
+
+do_compile () {
+ :
+}
+
+do_install () {
+ install -d ${D}${sysconfdir} ${D}${sbindir} ${D}${base_sbindir} ${D}${localstatedir}/run/resolvconf/interface
+ install -d ${D}${mandir}/man8 ${D}${docdir}/${P}
+ cp -pPR etc/* ${D}${sysconfdir}/
+ install -m 0755 bin/resolvconf ${D}${base_sbindir}/
+ install -m 0644 README ${D}${docdir}/${P}/
+ install -m 0644 man/resolvconf.8 ${D}${mandir}/man8/
+}
+
+PACKAGE_ARCH = "all"
+
diff --git a/recipes/xorg-driver/files/0001-dpms.h-dpmsconst.h.patch b/recipes/xorg-driver/files/0001-dpms.h-dpmsconst.h.patch
deleted file mode 100644
index b8139f3adb..0000000000
--- a/recipes/xorg-driver/files/0001-dpms.h-dpmsconst.h.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From b608f4eb854983a051d2c9171a0ed730861587f5 Mon Sep 17 00:00:00 2001
-From: Thomas White <taw@bitwiz.org.uk>
-Date: Sun, 20 Sep 2009 00:08:09 +0100
-Subject: [PATCH] dpms.h -> dpmsconst.h
-
----
- src/glamo-display.c | 2 +-
- 1 files changed, 1 insertions(+), 1 deletions(-)
-
-diff --git a/src/glamo-display.c b/src/glamo-display.c
-index 4562546..fede315 100644
---- a/src/glamo-display.c
-+++ b/src/glamo-display.c
-@@ -38,7 +38,7 @@
- #include <unistd.h>
-
- #define DPMS_SERVER
--#include <X11/extensions/dpms.h>
-+#include <X11/extensions/dpmsconst.h>
-
- #include "glamo.h"
- #include "glamo-regs.h"
---
-1.6.2.5
-
diff --git a/recipes/xorg-driver/xf86-video-glamo_git.bb b/recipes/xorg-driver/xf86-video-glamo_git.bb
index 91bfb967dd..a47b711bbe 100644
--- a/recipes/xorg-driver/xf86-video-glamo_git.bb
+++ b/recipes/xorg-driver/xf86-video-glamo_git.bb
@@ -12,4 +12,5 @@ DEPENDS += "libdrm"
DESCRIPTION = "X.Org X server -- Glamo display driver with KMS support"
+ARM_INSTRUCTION_SET = "arm"
EXTRA_OECONF = " --enable-kms "