aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2007-12-26 12:36:33 +0000
committerKoen Kooi <koen@openembedded.org>2007-12-26 12:36:33 +0000
commit219d38d250cddc81204428656918bd09ad3d9cfe (patch)
tree34a5fea2390c8943d505b4a48221f1f8b7b5c682
parent6bbbf4ddc955a0880178cf4126ac920b21fa2fd8 (diff)
downloadopenembedded-219d38d250cddc81204428656918bd09ad3d9cfe.tar.gz
linux-dht-walnut: switch to uImage
-rw-r--r--conf/machine/dht-walnut.conf1
-rw-r--r--packages/linux/linux-dht-walnut_2.6.20.bb6
2 files changed, 5 insertions, 2 deletions
diff --git a/conf/machine/dht-walnut.conf b/conf/machine/dht-walnut.conf
index a8a2d60c17..6eeb08825b 100644
--- a/conf/machine/dht-walnut.conf
+++ b/conf/machine/dht-walnut.conf
@@ -20,6 +20,7 @@ USE_VT = "0"
SERIAL_CONSOLE = "115200 ttyS0"
PREFERRED_VERSION_u-boot = "1.1.4"
+KERNEL_IMAGETYPE = "uImage"
#tune for the 405 cpu
require conf/machine/include/tune-ppc405.inc
diff --git a/packages/linux/linux-dht-walnut_2.6.20.bb b/packages/linux/linux-dht-walnut_2.6.20.bb
index 8c1d2b85e1..61836ac204 100644
--- a/packages/linux/linux-dht-walnut_2.6.20.bb
+++ b/packages/linux/linux-dht-walnut_2.6.20.bb
@@ -18,7 +18,6 @@ FILES_kernel-image = "/boot/zImage.elf"
export OS = "Linux"
ARCH = "ppc"
-KERNEL_OUTPUT = "arch/ppc/boot/images/zImage.elf"
do_stage_append () {
#need ppc platforms includes + friends in order for external kernel modules to compile as headers as still split
@@ -33,8 +32,11 @@ do_stage_append () {
do_install_append () {
install -d ${DEPLOY_DIR_IMAGE}
- install -m 0755 arch/ppc/boot/images/zImage.elf \
+ if [ -e arch/ppc/boot/images/zImage.elf ] ; then
+ cp -a arch/ppc/boot/images/zImage.elf arch/ppc/boot/images/zImage
+ install -m 0755 arch/ppc/boot/images/zImage.elf \
${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGETYPE}-${PV}-${MACHINE}-${DATETIME}.elf
+ fi
install -m 0755 vmlinux ${DEPLOY_DIR_IMAGE}/
}