aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael 'Mickey' Lauer <mickey@vanille-media.de>2008-11-12 23:19:08 +0100
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>2008-11-15 21:31:30 +0100
commit21978b02c54fa1c38bff13fe81106779c60f71b8 (patch)
tree0de8034dafad55986b63af9908ba6b9ab7723182
parent1f0b2db0f01f4a97a0185f5ac4c2274d3f0611a2 (diff)
downloadopenembedded-21978b02c54fa1c38bff13fe81106779c60f71b8.tar.gz
boost 1.33.1: apply patch for gcc4.1, courtesy Sander van Grieken. closes #4710
remove 1.33.0
-rw-r--r--packages/boost/boost_1.33.0.bb8
-rw-r--r--packages/boost/boost_1.33.1.bb14
-rw-r--r--packages/boost/files/gcc41.patch14
3 files changed, 22 insertions, 14 deletions
diff --git a/packages/boost/boost_1.33.0.bb b/packages/boost/boost_1.33.0.bb
deleted file mode 100644
index 520cf43a8d..0000000000
--- a/packages/boost/boost_1.33.0.bb
+++ /dev/null
@@ -1,8 +0,0 @@
-include boost.inc
-
-PR = "r1"
-
-SRC_URI = "${SOURCEFORGE_MIRROR}/boost/${BOOST_P}.tar.bz2"
-#SRC_URI += "file://unit_test_log10f.patch;patch=1"
-SRC_URI += "file://linux-uclibc.patch;patch=1"
-
diff --git a/packages/boost/boost_1.33.1.bb b/packages/boost/boost_1.33.1.bb
index 840be8b784..71b8fc15b3 100644
--- a/packages/boost/boost_1.33.1.bb
+++ b/packages/boost/boost_1.33.1.bb
@@ -1,9 +1,11 @@
include boost.inc
+PR = "r3"
-PR = "r2"
+SRC_URI = "\
+ ${SOURCEFORGE_MIRROR}/boost/${BOOST_P}.tar.bz2 \
+ file://linux-uclibc.patch;patch=1 \
+ file://atomic_count_gcc_atomicity.patch;patch=1 \
+ file://gcc43.patch;patch=1 \
+ file://gcc41.patch;patch=1 \
+"
-SRC_URI = "${SOURCEFORGE_MIRROR}/boost/${BOOST_P}.tar.bz2"
-#SRC_URI += "file://unit_test_log10f.patch;patch=1"
-SRC_URI += "file://linux-uclibc.patch;patch=1"
-SRC_URI += "file://atomic_count_gcc_atomicity.patch;patch=1"
-SRC_URI += "file://gcc43.patch;patch=1"
diff --git a/packages/boost/files/gcc41.patch b/packages/boost/files/gcc41.patch
new file mode 100644
index 0000000000..f91d1adf2b
--- /dev/null
+++ b/packages/boost/files/gcc41.patch
@@ -0,0 +1,14 @@
+diff -ur boost_1_33_1.orig/boost/bind.hpp boost_1_33_1/boost/bind.hpp
+--- boost_1_33_1.orig/boost/bind.hpp 2008-10-11 10:30:03.000000000 +0200
++++ boost_1_33_1/boost/bind.hpp 2008-10-11 10:41:25.000000000 +0200
+@@ -28,6 +28,10 @@
+ #include <boost/bind/arg.hpp>
+ #include <boost/detail/workaround.hpp>
+
++#if __GNUC__ == 4 && __GNUC_MINOR__ == 1
++# include <boost/visit_each.hpp>
++#endif
++
+ // Borland-specific bug, visit_each() silently fails to produce code
+
+ #if defined(__BORLANDC__)