aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSteffen Sledz <sledz@dresearch-fe.de>2011-11-30 08:57:54 +0000
committerTom Rini <trini@kernel.crashing.org>2011-12-01 07:56:34 -0700
commit05041650874afe143f3f35a0821b9ddbd191fb40 (patch)
tree29846eb367af52dabe026933b618afe6668a268d
parentccecfe6c9b950be096225a06f635cf4a7d0243fb (diff)
downloadopenembedded-05041650874afe143f3f35a0821b9ddbd191fb40.tar.gz
gypsy: fix packaging of DBus starter script
A wrong path had avoided the packaging of the dbus starter script /usr/share/dbus-1/system-services/org.freedesktop.Gypsy.service. Signed-off-by: Steffen Sledz <sledz@dresearch-fe.de> Acked-by: Paul Menzel <paulepanter@users.sourceforge.net> Signed-off-by: Tom Rini <trini@kernel.crashing.org>
-rw-r--r--recipes/gypsy/gypsy.inc4
-rw-r--r--recipes/gypsy/gypsy_0.7.bb2
2 files changed, 5 insertions, 1 deletions
diff --git a/recipes/gypsy/gypsy.inc b/recipes/gypsy/gypsy.inc
index eab062c5d6..964e336c01 100644
--- a/recipes/gypsy/gypsy.inc
+++ b/recipes/gypsy/gypsy.inc
@@ -3,6 +3,8 @@ LICENSE = "GPL"
SECTION = "x11"
DEPENDS = "glib-2.0 dbus-glib bluez4 libxslt-native"
+INC_PR = "r1"
+
inherit autotools pkgconfig
do_configure_prepend () {
@@ -14,6 +16,6 @@ PACKAGES += "libgypsy libgypsy-dev libgypsy-dbg"
FILES_lib${PN} = "${libdir}/lib*.so*"
FILES_lib${PN}-dev = "${includedir}/* ${libdir}/*.la ${libdir}/*.a ${libdir}/pkgconfig"
FILES_lib${PN}-dbg = "${libdir}/.debug"
-FILES_${PN} = "${datadir}/dbus-1/services/ ${libexecdir}/gypsy-daemon ${sysconfdir}/dbus-1/system.d/*"
+FILES_${PN} = "${datadir}/dbus-1/system-services/* ${libexecdir}/gypsy-daemon ${sysconfdir}/dbus-1/system.d/*"
FILES_${PN}-dbg ="${libexecdir}/.debug*"
CONFFILES_${PN} = "${sysconfdir}/dbus-1/system.d/Gypsy.conf"
diff --git a/recipes/gypsy/gypsy_0.7.bb b/recipes/gypsy/gypsy_0.7.bb
index 8cd8760a07..054c7840f7 100644
--- a/recipes/gypsy/gypsy_0.7.bb
+++ b/recipes/gypsy/gypsy_0.7.bb
@@ -1,5 +1,7 @@
require gypsy.inc
+PR = "${INC_PR}.0"
+
SRC_URI = "http://gypsy.freedesktop.org/releases/gypsy-0.7.tar.gz;name=gypsy \
file://docs-reference-am.patch \
file://remove-werror.patch \