aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruno Randolf <br1@subnet.at>2004-12-20 14:19:45 +0000
committerBruno Randolf <br1@subnet.at>2004-12-20 14:19:45 +0000
commit0158ae8f0ff7abe3a436dcd63f7af8618bbd0533 (patch)
tree53db0f8d37907ec3ffb094fcc0c036f3c3468a21
parentdc6b5a4fa396c3fc79c30300cc95b924c584ae31 (diff)
downloadopenembedded-0158ae8f0ff7abe3a436dcd63f7af8618bbd0533.tar.gz
fixed hotplug:
ispnp.rc exit, not return. added pciutils pcimodules patch. added hotplug script for usb-storage to load sd_mod. BKrev: 41c6df81gZaR8uZVtby7Kxah22qr4A
-rw-r--r--conf/distro/nylon.conf1
-rw-r--r--packages/hotplug/hotplug-20040920/isapnp-exit.diff0
-rw-r--r--packages/hotplug/hotplug-20040920/usb-storage0
-rw-r--r--packages/hotplug/hotplug_20040920.bb63
-rw-r--r--packages/meta/nylon-feed.bb95
-rw-r--r--packages/pciutils/pciutils-2.1.11/pcimodules-pciutils-2.1.11.diff0
-rw-r--r--packages/pciutils/pciutils_2.1.11.bb25
7 files changed, 184 insertions, 0 deletions
diff --git a/conf/distro/nylon.conf b/conf/distro/nylon.conf
index df5ce3078e..16f64be13e 100644
--- a/conf/distro/nylon.conf
+++ b/conf/distro/nylon.conf
@@ -32,6 +32,7 @@ PREFERRED_VERSION_binutils = "2.14.90.0.7"
PREFERRED_VERSION_unik-olsrd = "0.4.8"
PREFERRED_VERSION_prism54-firmware = "1.0.3.0"
+PREFERRED_VERSION_usbutils = "0.11"
# use meshcub.org mirrors
CVS_TARBALL_STASH = "http://meshcube.org/nylon/unstable/sources/"
diff --git a/packages/hotplug/hotplug-20040920/isapnp-exit.diff b/packages/hotplug/hotplug-20040920/isapnp-exit.diff
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/hotplug/hotplug-20040920/isapnp-exit.diff
diff --git a/packages/hotplug/hotplug-20040920/usb-storage b/packages/hotplug/hotplug-20040920/usb-storage
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/hotplug/hotplug-20040920/usb-storage
diff --git a/packages/hotplug/hotplug_20040920.bb b/packages/hotplug/hotplug_20040920.bb
index e69de29bb2..6948125c65 100644
--- a/packages/hotplug/hotplug_20040920.bb
+++ b/packages/hotplug/hotplug_20040920.bb
@@ -0,0 +1,63 @@
+DESCRIPTION = "This package contains the scripts necessary \
+for hotplug Linux support, and lets you plug in new devices \
+and use them immediately."
+HOMEPAGE = "http://linux-hotplug.sourceforge.net/"
+LICENSE = "GPL"
+SECTION = "base"
+PR = "r5"
+
+SRC_URI = "ftp://ftp.kernel.org/pub/linux/utils/kernel/hotplug/hotplug-2004_09_20.tar.gz \
+ file://userspecified_hcd.patch;patch=1 \
+ file://fix-net.agent \
+ file://update-usb.usermap \
+ file://logcheck-ignore \
+ file://sleeve.agent \
+ file://sleeve.rc \
+ file://mmc.agent \
+ file://usbd.agent \
+ file://usbd \
+ file://sysconfig-hotplug \
+ file://sysconfig-usb \
+ file://isapnp-exit.diff;patch=1 \
+ file://usb-storage"
+
+S = "${WORKDIR}/hotplug-2004_09_20"
+
+INITSCRIPT_NAME = "hotplug"
+INITSCRIPT_PARAMS = "start 40 S . stop 89 0 6 ."
+
+inherit update-rc.d
+
+do_compile () {
+ :
+}
+
+oldmandir := "${mandir}"
+oldsbindir := "${sbindir}"
+prefix = ""
+exec_prefix = ""
+FILES_hotplug_append = " ${oldsbindir}"
+FILES_hotplug-doc_append = " ${oldmandir}"
+
+export DEBFIX = "sed -e 's:sysconfig/usb:default/hotplug.usb:'"
+do_install () {
+ install -d ${D}/${sysconfdir}/logcheck/ignore.d
+ install -d ${D}/${oldmandir}
+ install -d ${D}/${oldsbindir}
+ #install -d ${D}/${sysconfdir}/default
+ oe_runmake prefix=${D}${prefix} exec_prefix=${D}${exec_prefix} \
+ etcdir=${D}${sysconfdir} sbindir=${D}${sbindir} \
+ mandir=${D}${oldmandir} install
+ sh ${WORKDIR}/fix-net.agent ${D}
+ install -m 0755 ${WORKDIR}/update-usb.usermap ${D}/${oldsbindir}/
+ install -m 0644 ${WORKDIR}/logcheck-ignore ${D}/${sysconfdir}/logcheck/ignore.d/hotplug
+ install -m 0755 ${WORKDIR}/sleeve.agent ${D}${sysconfdir}/hotplug/
+ install -m 0755 ${WORKDIR}/sleeve.rc ${D}${sysconfdir}/hotplug/
+ install -m 0755 ${WORKDIR}/mmc.agent ${D}${sysconfdir}/hotplug/
+ install -m 0755 ${WORKDIR}/usbd.agent ${D}${sysconfdir}/hotplug/
+ #install -m 0755 ${WORKDIR}/usbd ${D}${sysconfdir}/default/usbd
+ install -d ${D}${sysconfdir}/sysconfig
+ install -m 0644 ${WORKDIR}/sysconfig-hotplug ${D}${sysconfdir}/sysconfig/hotplug
+ install -m 0644 ${WORKDIR}/sysconfig-usb ${D}/${sysconfdir}/sysconfig/usb
+ install -m 0755 ${WORKDIR}/usb-storage ${D}${sysconfdir}/hotplug/usb
+}
diff --git a/packages/meta/nylon-feed.bb b/packages/meta/nylon-feed.bb
index e69de29bb2..63b99e3bf2 100644
--- a/packages/meta/nylon-feed.bb
+++ b/packages/meta/nylon-feed.bb
@@ -0,0 +1,95 @@
+DEPENDS = " \
+base-files \
+bash \
+bridge-utils \
+busybox \
+chillispot \
+db3 \
+ddclient \
+dhcp-forwarder \
+dhcp \
+dnsmasq \
+expat \
+gdb \
+glib-2.0 \
+glibc \
+gmp \
+gnupg \
+hostap-modules \
+hostap-utils \
+hostap-daemon \
+hotplug \
+htb-init \
+ifplugd \
+initscripts \
+iperf \
+ipkg \
+iproute2 \
+iptables \
+virtual/kernel \
+kismet \
+less \
+libcgicc \
+libmail-sendmail-perl \
+libnetserver-generic-perl \
+libpcap \
+lsof \
+lzo \
+madwifi-modules \
+maradns \
+mc \
+mobilemesh \
+modutils \
+mtd \
+mtr \
+nano \
+ncurses \
+netbase \
+netperf \
+net-snmp \
+ntp \
+nylon-scripts \
+nylon-statistics \
+openssh \
+openssl \
+openvpn \
+openswan \
+pciutils \
+pcre \
+perl \
+ppp \
+ppp-dsl \
+rp-pppoe \
+rrdtool \
+prism2-firmware-update \
+prism54-module \
+prism54-firmware \
+shorewall \
+stunnel \
+sysvinit \
+tcpdump \
+tinc \
+timezones \
+unik-olsrd \
+usbutils \
+vtun \
+wireless-tools \
+wlan-ng-modules \
+zlib \
+"
+
+# TODO:
+# ksymoops / binutils
+# strace: SYS_read?
+# gdb-cross: install paths, sdk?
+# screen: sgttyb?
+# nocat?
+# pptp
+# meshroaming
+
+do_index() {
+ ipkg-make-index -r ${DEPLOY_DIR_IPK}/Packages -p ${DEPLOY_DIR_IPK}/Packages -l ${DEPLOY_DIR_IPK}/Packages.filelist -m ${DEPLOY_DIR_IPK}
+}
+
+addtask index before do_build after do_install
+
diff --git a/packages/pciutils/pciutils-2.1.11/pcimodules-pciutils-2.1.11.diff b/packages/pciutils/pciutils-2.1.11/pcimodules-pciutils-2.1.11.diff
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/pciutils/pciutils-2.1.11/pcimodules-pciutils-2.1.11.diff
diff --git a/packages/pciutils/pciutils_2.1.11.bb b/packages/pciutils/pciutils_2.1.11.bb
index e69de29bb2..60008cfe45 100644
--- a/packages/pciutils/pciutils_2.1.11.bb
+++ b/packages/pciutils/pciutils_2.1.11.bb
@@ -0,0 +1,25 @@
+SECTION = "console/utils"
+DESCRIPTION = 'The PCI Utilities package contains a library for portable access \
+to PCI bus configuration space and several utilities based on this library.'
+HOMEPAGE = "http://atrey.karlin.mff.cuni.cz/~mj/pciutils.shtml"
+LICENSE = "GPLv2"
+
+PR="r1"
+
+SRC_URI = "ftp://ftp.kernel.org/pub/software/utils/pciutils/pciutils-${PV}.tar.bz2 \
+ file://configure.patch;patch=1 \
+ file://configure-uclibc.patch;patch=1 \
+ file://pcimodules-pciutils-2.1.11.diff;patch=1"
+
+do_configure () {
+ (cd lib && ./configure ${datadir} ${PV} ${TARGET_OS} 2.4.21 ${TARGET_ARCH})
+}
+
+export PREFIX = "${D}/${prefix}"
+export SBINDIR = "${D}/${sbindir}"
+export SHAREDIR = "${D}/${datadir}"
+export MANDIR = "${D}/${mandir}"
+
+do_install () {
+ oe_runmake install
+}