summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support')
-rw-r--r--meta/recipes-support/gnutls/gnutls/remove-gets.patch41
-rw-r--r--meta/recipes-support/gnutls/gnutls_2.12.20.bb3
2 files changed, 43 insertions, 1 deletions
diff --git a/meta/recipes-support/gnutls/gnutls/remove-gets.patch b/meta/recipes-support/gnutls/gnutls/remove-gets.patch
new file mode 100644
index 0000000000..8b7df6286a
--- /dev/null
+++ b/meta/recipes-support/gnutls/gnutls/remove-gets.patch
@@ -0,0 +1,41 @@
+eglibc 2.16 has removed gets completely
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+Upstream-Status: Pending
+Index: gnutls-2.12.20/gl/stdio.in.h
+===================================================================
+--- gnutls-2.12.20.orig/gl/stdio.in.h 2012-03-01 07:47:48.000000000 -0800
++++ gnutls-2.12.20/gl/stdio.in.h 2012-07-03 18:17:57.191637189 -0700
+@@ -710,11 +710,13 @@
+ _GL_CXXALIAS_SYS (gets, char *, (char *s));
+ # undef gets
+ # endif
++# if defined gets
+ _GL_CXXALIASWARN (gets);
+ /* It is very rare that the developer ever has full control of stdin,
+ so any use of gets warrants an unconditional warning. Assume it is
+ always declared, since it is required by C89. */
+ _GL_WARN_ON_USE (gets, "gets is a security hole - use fgets instead");
++# endif
+ #endif
+
+
+Index: gnutls-2.12.20/lib/gl/stdio.in.h
+===================================================================
+--- gnutls-2.12.20.orig/lib/gl/stdio.in.h 2012-03-01 07:53:13.000000000 -0800
++++ gnutls-2.12.20/lib/gl/stdio.in.h 2012-07-03 18:18:56.351639640 -0700
+@@ -710,11 +710,13 @@
+ _GL_CXXALIAS_SYS (gets, char *, (char *s));
+ # undef gets
+ # endif
++# if defined gets
+ _GL_CXXALIASWARN (gets);
+ /* It is very rare that the developer ever has full control of stdin,
+ so any use of gets warrants an unconditional warning. Assume it is
+ always declared, since it is required by C89. */
+ _GL_WARN_ON_USE (gets, "gets is a security hole - use fgets instead");
++# endif
+ #endif
+
+
diff --git a/meta/recipes-support/gnutls/gnutls_2.12.20.bb b/meta/recipes-support/gnutls/gnutls_2.12.20.bb
index 010f179b9f..3a10dbf924 100644
--- a/meta/recipes-support/gnutls/gnutls_2.12.20.bb
+++ b/meta/recipes-support/gnutls/gnutls_2.12.20.bb
@@ -1,11 +1,12 @@
require gnutls.inc
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.2"
SRC_URI += "file://gnutls-openssl.patch \
file://correct_rpl_gettimeofday_signature.patch \
file://configure-fix.patch \
${@['', 'file://fix-gettext-version.patch'][bb.data.inherits_class('native', d) or (not ((d.getVar("INCOMPATIBLE_LICENSE", True) or "").find("GPLv3") != -1))]} \
+ file://remove-gets.patch \
"
SRC_URI[md5sum] = "f1dea97da5d4dcdbc675720c9aad9ee3"