summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/user-creation/xuser-account_0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/user-creation/xuser-account_0.1.bb')
-rw-r--r--meta/recipes-support/user-creation/xuser-account_0.1.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta/recipes-support/user-creation/xuser-account_0.1.bb b/meta/recipes-support/user-creation/xuser-account_0.1.bb
index 639b01f6eb..80a429c6d3 100644
--- a/meta/recipes-support/user-creation/xuser-account_0.1.bb
+++ b/meta/recipes-support/user-creation/xuser-account_0.1.bb
@@ -6,6 +6,9 @@ SRC_URI = "file://system-xuser.conf"
inherit allarch useradd
+S = "${WORKDIR}/sources"
+UNPACKDIR = "${S}"
+
do_configure() {
:
}
@@ -15,7 +18,7 @@ do_compile() {
}
do_install() {
- install -D -m 0644 ${WORKDIR}/system-xuser.conf ${D}${sysconfdir}/dbus-1/system.d/system-xuser.conf
+ install -D -m 0644 ${UNPACKDIR}/system-xuser.conf ${D}${sysconfdir}/dbus-1/system.d/system-xuser.conf
}
FILES:${PN} = "${sysconfdir}/dbus-1/system.d/system-xuser.conf"