summaryrefslogtreecommitdiffstats
path: root/meta/recipes-multimedia/webp
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-multimedia/webp')
-rw-r--r--meta/recipes-multimedia/webp/libwebp_1.4.0.bb (renamed from meta/recipes-multimedia/webp/libwebp_1.0.0.bb)16
1 files changed, 10 insertions, 6 deletions
diff --git a/meta/recipes-multimedia/webp/libwebp_1.0.0.bb b/meta/recipes-multimedia/webp/libwebp_1.4.0.bb
index 1a9679f9dc..d922970479 100644
--- a/meta/recipes-multimedia/webp/libwebp_1.0.0.bb
+++ b/meta/recipes-multimedia/webp/libwebp_1.4.0.bb
@@ -9,13 +9,12 @@ DESCRIPTION = "WebP is a method of lossy and lossless compression that can be \
HOMEPAGE = "https://developers.google.com/speed/webp/"
SECTION = "libs"
-LICENSE = "BSD"
+LICENSE = "BSD-3-Clause"
LIC_FILES_CHKSUM = "file://COPYING;md5=6e8dee932c26f2dab503abf70c96d8bb \
file://PATENTS;md5=c6926d0cb07d296f886ab6e0cc5a85b7"
SRC_URI = "http://downloads.webmproject.org/releases/webp/${BP}.tar.gz"
-SRC_URI[md5sum] = "967b8f087cb392e6cc94d5e116a120c0"
-SRC_URI[sha256sum] = "84259c4388f18637af3c5a6361536d754a5394492f91be1abc2e981d4983225b"
+SRC_URI[sha256sum] = "61f873ec69e3be1b99535634340d5bde750b2e4447caa1db9f61be3fd49ab1e5"
UPSTREAM_CHECK_URI = "http://downloads.webmproject.org/releases/webp/index.html"
@@ -25,11 +24,14 @@ EXTRA_OECONF = " \
--enable-libwebpdemux \
--enable-threading \
"
+
# Do not trust configure to determine if neon is available.
#
-EXTRA_OECONF_append_arm = " \
+EXTRA_OECONF_ARM = " \
${@bb.utils.contains("TUNE_FEATURES","neon","--enable-neon","--disable-neon",d)} \
"
+EXTRA_OECONF:append:arm = " ${EXTRA_OECONF_ARM}"
+EXTRA_OECONF:append:armeb = " ${EXTRA_OECONF_ARM}"
inherit autotools lib_package
@@ -49,5 +51,7 @@ PACKAGECONFIG[gl] = "--enable-gl,--disable-gl,mesa-glut"
PACKAGES =+ "${PN}-gif2webp"
-DESCRIPTION_${PN}-gif2webp = "Simple tool to convert animated GIFs to WebP"
-FILES_${PN}-gif2webp = "${bindir}/gif2webp"
+DESCRIPTION:${PN}-gif2webp = "Simple tool to convert animated GIFs to WebP"
+FILES:${PN}-gif2webp = "${bindir}/gif2webp"
+
+BBCLASSEXTEND += "native nativesdk"