summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/linux/linux-yocto-tiny_4.14.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-kernel/linux/linux-yocto-tiny_4.14.bb')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_4.14.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_4.14.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_4.14.bb
new file mode 100644
index 0000000000..bf4b0ac4f6
--- /dev/null
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_4.14.bb
@@ -0,0 +1,25 @@
+KBRANCH ?= "v4.14/standard/tiny/common-pc"
+LINUX_KERNEL_TYPE = "tiny"
+KCONFIG_MODE = "--allnoconfig"
+
+require recipes-kernel/linux/linux-yocto.inc
+
+LINUX_VERSION ?= "4.14.16"
+
+KMETA = "kernel-meta"
+KCONF_BSP_AUDIT_LEVEL = "2"
+
+SRCREV_machine ?= "ae0fb21fdde3df106d7dad76620bdf39721425e2"
+SRCREV_meta ?= "0e964663a7978bdb459c28f3777e1b6dfe97d93d"
+
+PV = "${LINUX_VERSION}+git${SRCPV}"
+
+SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine \
+ git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-4.14;destsuffix=${KMETA}"
+
+COMPATIBLE_MACHINE = "qemux86|qemux86-64"
+
+# Functionality flags
+KERNEL_FEATURES = ""
+
+KERNEL_DEVICETREE_qemuarm = "versatile-pb.dtb"