summaryrefslogtreecommitdiffstats
path: root/meta/recipes-graphics/fontconfig/fontconfig-native_2.9.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-graphics/fontconfig/fontconfig-native_2.9.0.bb')
-rw-r--r--meta/recipes-graphics/fontconfig/fontconfig-native_2.9.0.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta/recipes-graphics/fontconfig/fontconfig-native_2.9.0.bb b/meta/recipes-graphics/fontconfig/fontconfig-native_2.9.0.bb
new file mode 100644
index 0000000000..cee94de534
--- /dev/null
+++ b/meta/recipes-graphics/fontconfig/fontconfig-native_2.9.0.bb
@@ -0,0 +1,14 @@
+require fontconfig_${PV}.bb
+inherit native
+DEPENDS = "freetype-native expat-native zlib-native"
+
+EXTRA_OEMAKE = ""
+EXTRA_OECONF = "${@[' --disable-docs',' --disable-docs --with-freetype-config=%s/freetype-config' % d.getVar('STAGING_BINDIR', True)][os.path.isfile('%s/freetype-config' % d.getVar('STAGING_BINDIR', True))]}"
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}-${PV}:"
+
+do_install_append () {
+ install -d ${D}${bindir}/
+ install fc-lang/fc-lang ${D}${bindir}/
+ install fc-glyphname/fc-glyphname ${D}${bindir}/
+}