summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/lsb/lsbsetup_0.9.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/lsb/lsbsetup_0.9.bb')
-rw-r--r--meta/recipes-extended/lsb/lsbsetup_0.9.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/meta/recipes-extended/lsb/lsbsetup_0.9.bb b/meta/recipes-extended/lsb/lsbsetup_0.9.bb
index 5fd0584fb1..8f7da537eb 100644
--- a/meta/recipes-extended/lsb/lsbsetup_0.9.bb
+++ b/meta/recipes-extended/lsb/lsbsetup_0.9.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "auto-setup environment for lsb test"
SECTION = "console/utils"
PRIORITY = "required"
LICENSE = "GPLv2"
-PR = "r1"
+PR = "r2"
LIC_FILES_CHKSUM = "file://LSB_Setup.sh;beginline=3;endline=16;md5=97451c7c0786ce5bbe9ac58042945583"
@@ -14,4 +14,9 @@ do_install() {
# Only install file if it has a contents
install -d ${D}/usr/bin
install -m 0755 ${S}/LSB_Setup.sh ${D}/usr/bin
+ install -d ${D}/usr/lib/lsb
+ ln -sf ${base_sbindir}/chkconfig ${D}/${libdir}/lsb/install_initd
+ ln -sf ${base_sbindir}/chkconfig ${D}/${libdir}/lsb/remove_initd
}
+
+FILES_${PN} += "${libdir}/lsb"