summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/go/go_1.19.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/go/go_1.19.bb')
-rw-r--r--meta/recipes-devtools/go/go_1.19.bb18
1 files changed, 0 insertions, 18 deletions
diff --git a/meta/recipes-devtools/go/go_1.19.bb b/meta/recipes-devtools/go/go_1.19.bb
deleted file mode 100644
index 98977673ee..0000000000
--- a/meta/recipes-devtools/go/go_1.19.bb
+++ /dev/null
@@ -1,18 +0,0 @@
-require go-${PV}.inc
-require go-target.inc
-
-inherit linuxloader
-
-CGO_LDFLAGS:append:mips = " -no-pie"
-
-export GO_LDSO = "${@get_linuxloader(d)}"
-export CC_FOR_TARGET = "gcc"
-export CXX_FOR_TARGET = "g++"
-
-# mips/rv64 doesn't support -buildmode=pie, so skip the QA checking for mips/riscv32 and its
-# variants.
-python() {
- if 'mips' in d.getVar('TARGET_ARCH',True) or 'riscv32' in d.getVar('TARGET_ARCH',True):
- d.appendVar('INSANE_SKIP:%s' % d.getVar('PN',True), " textrel")
-}
-