summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/diffstat
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/diffstat')
-rw-r--r--meta/recipes-devtools/diffstat/diffstat/avoid-check-user-break-cc.patch12
-rw-r--r--meta/recipes-devtools/diffstat/diffstat_1.66.bb (renamed from meta/recipes-devtools/diffstat/diffstat_1.61.bb)11
2 files changed, 14 insertions, 9 deletions
diff --git a/meta/recipes-devtools/diffstat/diffstat/avoid-check-user-break-cc.patch b/meta/recipes-devtools/diffstat/diffstat/avoid-check-user-break-cc.patch
index 2df2d00185..46f1cfabcf 100644
--- a/meta/recipes-devtools/diffstat/diffstat/avoid-check-user-break-cc.patch
+++ b/meta/recipes-devtools/diffstat/diffstat/avoid-check-user-break-cc.patch
@@ -1,3 +1,8 @@
+From 708c765ffb41ecc734316f69043583312fe444bd Mon Sep 17 00:00:00 2001
+From: Kai Kang <kai.kang@windriver.com>
+Date: Tue, 15 May 2018 17:17:01 +0800
+Subject: [PATCH] diffstat: fix wrong evaluation of CC
+
Upstream-Status: Inappropriate [oe specific]
m4 function CF_CC_ENV_FLAGS checks whether variable CC contains options '-I', '-U'
@@ -7,15 +12,16 @@ be included in CC. And then CC will be wrongly filtered.
So comment out CF_CC_ENV_FLAGS from function CF_PROG_CC.
Signed-off-by: Kai Kang <kai.kang@windriver.com>
+
---
aclocal.m4 | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/aclocal.m4 b/aclocal.m4
-index 420fe83..eb73ea9 100644
+index d4bd283..1b653c4 100644
--- a/aclocal.m4
+++ b/aclocal.m4
-@@ -1114,7 +1114,7 @@ CF_GCC_VERSION
+@@ -1522,7 +1522,7 @@ CF_GCC_VERSION
CF_ACVERSION_CHECK(2.52,
[AC_PROG_CC_STDC],
[CF_ANSI_CC_REQD])
@@ -23,4 +29,4 @@ index 420fe83..eb73ea9 100644
+dnl CF_CC_ENV_FLAGS
])dnl
dnl ---------------------------------------------------------------------------
- dnl CF_PROG_GROFF version: 2 updated: 2015/07/04 11:16:27
+ dnl CF_PROG_GROFF version: 3 updated: 2018/01/07 13:16:19
diff --git a/meta/recipes-devtools/diffstat/diffstat_1.61.bb b/meta/recipes-devtools/diffstat/diffstat_1.66.bb
index 1a76e78c15..d59379fd2b 100644
--- a/meta/recipes-devtools/diffstat/diffstat_1.61.bb
+++ b/meta/recipes-devtools/diffstat/diffstat_1.66.bb
@@ -5,17 +5,14 @@ reviewing large, complex patch files."
HOMEPAGE = "http://invisible-island.net/diffstat/"
SECTION = "devel"
LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://install-sh;endline=42;md5=b3549726c1022bee09c174c72a0ca4a5"
+LIC_FILES_CHKSUM = "file://COPYING;md5=5713b4719a66a6527e6301e8f8745877"
SRC_URI = "http://invisible-mirror.net/archives/${BPN}/${BP}.tgz \
file://run-ptest \
file://avoid-check-user-break-cc.patch \
-"
+ "
-SRC_URI[md5sum] = "c048a32d55d8bd6724f382baf41f325f"
-SRC_URI[sha256sum] = "25359e0c27183f997b36c9202583b5dc2df390c20e22a92606af4bf7856a55ee"
-
-S = "${WORKDIR}/diffstat-${PV}"
+SRC_URI[sha256sum] = "f54531bbe32e8e0fa461f018b41e3af516b632080172f361f05e50367ecbb69e"
inherit autotools gettext ptest
@@ -26,3 +23,5 @@ LDFLAGS += "${TOOLCHAIN_OPTIONS}"
do_install_ptest() {
cp -r ${S}/testing ${D}${PTEST_PATH}
}
+
+BBCLASSEXTEND = "nativesdk"