summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/coreutils/coreutils-8.22
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/coreutils/coreutils-8.22')
-rw-r--r--meta/recipes-core/coreutils/coreutils-8.22/dummy_help2man.patch22
-rw-r--r--meta/recipes-core/coreutils/coreutils-8.22/fix-for-dummy-man-usage.patch31
-rw-r--r--meta/recipes-core/coreutils/coreutils-8.22/remove-usr-local-lib-from-m4.patch31
3 files changed, 84 insertions, 0 deletions
diff --git a/meta/recipes-core/coreutils/coreutils-8.22/dummy_help2man.patch b/meta/recipes-core/coreutils/coreutils-8.22/dummy_help2man.patch
new file mode 100644
index 0000000000..4757f52aa0
--- /dev/null
+++ b/meta/recipes-core/coreutils/coreutils-8.22/dummy_help2man.patch
@@ -0,0 +1,22 @@
+Upstream-Status: Inappropriate [disable feature]
+
+Signed-off-by: Marko Lindqvist <cazfi74@gmail.com>
+diff -Nurd coreutils-8.21/man/local.mk coreutils-8.21/man/local.mk
+--- coreutils-8.21/man/local.mk 2013-02-05 16:01:21.000000000 +0200
++++ coreutils-8.21/man/local.mk 2013-03-23 09:12:53.360470192 +0200
+@@ -19,11 +19,11 @@
+ EXTRA_DIST += man/help2man man/dummy-man
+
+ ## Graceful degradation for systems lacking perl.
+-if HAVE_PERL
+-run_help2man = $(PERL) -- $(srcdir)/man/help2man
+-else
++#if HAVE_PERL
++#run_help2man = $(PERL) -- $(srcdir)/man/help2man
++#else
+ run_help2man = $(SHELL) $(srcdir)/man/dummy-man
+-endif
++#endif
+
+ man1_MANS = @man1_MANS@
+ EXTRA_DIST += $(man1_MANS:.1=.x)
diff --git a/meta/recipes-core/coreutils/coreutils-8.22/fix-for-dummy-man-usage.patch b/meta/recipes-core/coreutils/coreutils-8.22/fix-for-dummy-man-usage.patch
new file mode 100644
index 0000000000..b7e82609bd
--- /dev/null
+++ b/meta/recipes-core/coreutils/coreutils-8.22/fix-for-dummy-man-usage.patch
@@ -0,0 +1,31 @@
+Upstream-Status: Pending
+
+coreutils: fix for dummy-man usage
+
+The options should be before the final argument, otherwise, the following error
+would appear when compiling.
+
+"dummy-man: too many non-option arguments"
+
+Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
+---
+ man/local.mk | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/man/local.mk b/man/local.mk
+index 7cef5e3..dc0865f 100644
+--- a/man/local.mk
++++ b/man/local.mk
+@@ -189,8 +189,8 @@ man/yes.1: src/yes
+ && $(run_help2man) \
+ --source='$(PACKAGE_STRING)' \
+ --include=$(srcdir)/man/$$name.x \
+- --output=$$t/$$name.1 $$t/$$name \
+ --info-page='coreutils \(aq'$$name' invocation\(aq' \
++ --output=$$t/$$name.1 $$t/$$name \
+ && sed \
+ -e 's|$*\.td/||g' \
+ -e '/For complete documentation/d' \
+--
+1.7.9.5
+
diff --git a/meta/recipes-core/coreutils/coreutils-8.22/remove-usr-local-lib-from-m4.patch b/meta/recipes-core/coreutils/coreutils-8.22/remove-usr-local-lib-from-m4.patch
new file mode 100644
index 0000000000..2ef8a548ac
--- /dev/null
+++ b/meta/recipes-core/coreutils/coreutils-8.22/remove-usr-local-lib-from-m4.patch
@@ -0,0 +1,31 @@
+We have problem using hardcoded directories like /usr/local here
+which will be checked for cross builds. This is a special case which
+is valid for AIX only. We do not have AIX as one of our supported
+build host or target. Therefore we get rid of the hardcoded paths
+and make life easier for cross compilation process.
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+Upstream-Status: Inappropriate [Upstream does care for AIX while we may not]
+
+Index: coreutils-8.14/m4/getloadavg.m4
+===================================================================
+--- coreutils-8.14.orig/m4/getloadavg.m4 2011-09-19 08:09:24.000000000 -0700
++++ coreutils-8.14/m4/getloadavg.m4 2011-10-19 21:42:00.385533357 -0700
+@@ -41,16 +41,6 @@
+ [LIBS="-lutil $LIBS" gl_func_getloadavg_done=yes])
+ fi
+
+- if test $gl_func_getloadavg_done = no; then
+- # There is a commonly available library for RS/6000 AIX.
+- # Since it is not a standard part of AIX, it might be installed locally.
+- gl_getloadavg_LIBS=$LIBS
+- LIBS="-L/usr/local/lib $LIBS"
+- AC_CHECK_LIB([getloadavg], [getloadavg],
+- [LIBS="-lgetloadavg $LIBS" gl_func_getloadavg_done=yes],
+- [LIBS=$gl_getloadavg_LIBS])
+- fi
+-
+ # Set up the replacement function if necessary.
+ if test $gl_func_getloadavg_done = no; then
+ HAVE_GETLOADAVG=0