summaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/u-boot/u-boot-configure.inc
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-bsp/u-boot/u-boot-configure.inc')
-rw-r--r--meta/recipes-bsp/u-boot/u-boot-configure.inc3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot-configure.inc b/meta/recipes-bsp/u-boot/u-boot-configure.inc
index 04e0894752..378d675364 100644
--- a/meta/recipes-bsp/u-boot/u-boot-configure.inc
+++ b/meta/recipes-bsp/u-boot/u-boot-configure.inc
@@ -8,6 +8,8 @@ inherit uboot-config cml1
DEPENDS += "kern-tools-native"
+CONFIGURE_FILES = "${@d.getVar('UBOOT_MACHINE') or '.config'}"
+
do_configure () {
if [ -n "${UBOOT_CONFIG}" ]; then
unset i j
@@ -26,7 +28,6 @@ do_configure () {
unset j
done
unset i
- DEVTOOL_DISABLE_MENUCONFIG=true
else
if [ -n "${UBOOT_MACHINE}" ]; then
oe_runmake -C ${S} O=${B} ${UBOOT_MACHINE}