summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/recipes-devtools/rpm/rpm_5.4.9.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-devtools/rpm/rpm_5.4.9.bb b/meta/recipes-devtools/rpm/rpm_5.4.9.bb
index cdfb5ff4bc..6286771efa 100644
--- a/meta/recipes-devtools/rpm/rpm_5.4.9.bb
+++ b/meta/recipes-devtools/rpm/rpm_5.4.9.bb
@@ -358,13 +358,13 @@ FILES_${PN}-staticdev = " \
do_configure() {
# Disable tests!
- echo "all:" > tests/Makefile.am
+ echo "all:" > ${S}/tests/Makefile.am
- ./autogen.sh
+ ${S}/autogen.sh
# NASTY hack to make sure configure files the right pkg-config file...
sed -e 's/pkg-config --exists uuid/pkg-config --exists ossp-uuid/g' \
- -e 's/pkg-config uuid/pkg-config ossp-uuid/g' -i configure
+ -e 's/pkg-config uuid/pkg-config ossp-uuid/g' -i ${S}/configure
export varprefix=${localstatedir}
oe_runconf