summaryrefslogtreecommitdiffstats
path: root/scripts
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2015-02-17 14:42:18 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-02-17 14:17:24 +0000
commit8c9a25ae70d249b823ab2b0385d539eb8bbc1374 (patch)
tree12633793821f3f026d529c70b03f6d1b3676ea84 /scripts
parent47d31abef49494b408f6ba004638bac007782947 (diff)
downloadopenembedded-core-8c9a25ae70d249b823ab2b0385d539eb8bbc1374.tar.gz
test-dependencies.sh: strip only .bb suffix
* we were stripping too much when stripping recipe name from line like this: ERROR: Task 12016 (/some/patch/something.dot.bar.bb, do_fetch) failed with exit code '1' where the recipe name contains dots and doesn't end with _<version>.bb Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'scripts')
-rwxr-xr-xscripts/test-dependencies.sh2
1 files changed, 1 insertions, 1 deletions
diff --git a/scripts/test-dependencies.sh b/scripts/test-dependencies.sh
index 2bcc2ca4f6..e01acbecf7 100755
--- a/scripts/test-dependencies.sh
+++ b/scripts/test-dependencies.sh
@@ -141,7 +141,7 @@ build_all() {
bitbake -k $targets 2>&1 | tee -a ${OUTPUT1}/complete.log
RESULT+=${PIPESTATUS[0]}
grep "ERROR: Task.*failed" ${OUTPUT1}/complete.log > ${OUTPUT1}/failed-tasks.log
- cat ${OUTPUT1}/failed-tasks.log | sed 's@.*/@@g; s@_.*@@g; s@\..*@@g' | sort -u > ${OUTPUT1}/failed-recipes.log
+ cat ${OUTPUT1}/failed-tasks.log | sed 's@.*/@@g; s@_.*@@g; s@\.bb, .*@@g' | sort -u > ${OUTPUT1}/failed-recipes.log
}
build_every_recipe() {