summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorZhai Edwin <edwin.zhai@intel.com>2011-12-21 15:16:58 +0800
committerSaul Wold <sgw@linux.intel.com>2012-01-02 20:26:21 -0800
commitfb0cd3470e562f121803b722b16fd10620b79ff5 (patch)
treea63440d8d5f284f0f05b3670154a26804b5bcb61 /meta
parent43c2d366622ea52cba8a5b727d723c8ec30bd44b (diff)
downloadopenembedded-core-fb0cd3470e562f121803b722b16fd10620b79ff5.tar.gz
Add mini X core tasks
Signed-off-by: Zhai Edwin <edwin.zhai@intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/classes/core-image.bbclass2
-rw-r--r--meta/recipes-sato/tasks/task-core-x11-mini.bb45
2 files changed, 47 insertions, 0 deletions
diff --git a/meta/classes/core-image.bbclass b/meta/classes/core-image.bbclass
index 8e83d4abe1..c08895ff2d 100644
--- a/meta/classes/core-image.bbclass
+++ b/meta/classes/core-image.bbclass
@@ -13,6 +13,7 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3
# Available IMAGE_FEATURES:
#
# - apps-console-core
+# - x11-mini - minimal environment for X11 server
# - x11-base - X11 server + minimal desktop
# - x11-sato - OpenedHand Sato environment
# - x11-netbook - Metacity based environment for netbooks
@@ -29,6 +30,7 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3
# - debug-tweaks - makes an image suitable for development
#
PACKAGE_GROUP_apps-console-core = "task-core-apps-console"
+PACKAGE_GROUP_x11-mini = "task-core-x11-mini"
PACKAGE_GROUP_x11-base = "task-core-x11-base"
PACKAGE_GROUP_x11-sato = "task-core-x11-sato"
PACKAGE_GROUP_x11-netbook = "task-core-x11-netbook"
diff --git a/meta/recipes-sato/tasks/task-core-x11-mini.bb b/meta/recipes-sato/tasks/task-core-x11-mini.bb
new file mode 100644
index 0000000000..98189fe315
--- /dev/null
+++ b/meta/recipes-sato/tasks/task-core-x11-mini.bb
@@ -0,0 +1,45 @@
+#
+# Copyright (C) 2011 Intel Corporation
+#
+
+DESCRIPTION = "Tasks for core X11 applications"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58 \
+ file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+PR = "r0"
+
+PACKAGES = "\
+ task-core-x11-mini \
+ task-core-x11-mini-dbg \
+ task-core-x11-mini-dev \
+ "
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+XSERVER ?= "xserver-kdrive-fbdev"
+
+ALLOW_EMPTY = "1"
+
+ROOTLESS_X = "1"
+
+# xserver-common, x11-common
+VIRTUAL-RUNTIME_xserver_common ?= "x11-common"
+
+# elsa, xserver-nodm-init
+VIRTUAL-RUNTIME_graphical_init_manager ?= "xserver-nodm-init"
+
+
+RDEPENDS_task-core-x11-mini = "\
+ dbus \
+ pointercal \
+ matchbox-terminal \
+ matchbox-wm \
+ mini-x-session \
+ ${XSERVER} \
+ ${VIRTUAL-RUNTIME_xserver_common} \
+ ${VIRTUAL-RUNTIME_graphical_init_manager} \
+ liberation-fonts \
+ xauth \
+ xhost \
+ xset \
+ xrandr"