summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2015-05-14 10:31:05 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-05-14 11:41:10 +0100
commita641247d262971db2d44815c5a668e7e50bdaf4f (patch)
treea0bdbe126d557c3fc53136a9847b8f8f4fd3a8d3 /meta
parented51b382928ee5f14d524e08a00a0c8931c491c5 (diff)
downloadopenembedded-core-a641247d262971db2d44815c5a668e7e50bdaf4f.tar.gz
module/module-base/lttng-modules: Improve kernel module dependencies
If we have DEPENDS = "virtual/kernel" is means that the kernel module depends on the kernel's do_populate_sysroot task. This is not entirely desireable since that depends on do_install which depends on do_compile_kernelmodules and so on. In a situation where rm_work in involved this can cause some pretty length build cycles after the kernel workdir has been cleaned up by rm_work. As well as removing this, take the opportunity to clean up duplicated dependency lines, tweak the dependency of make_scripts for the same reason and generally try and make things more readable. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/classes/module-base.bbclass5
-rw-r--r--meta/classes/module.bbclass4
-rw-r--r--meta/recipes-kernel/lttng/lttng-modules_2.6.0.bb3
3 files changed, 4 insertions, 8 deletions
diff --git a/meta/classes/module-base.bbclass b/meta/classes/module-base.bbclass
index 3eb2e9226e..8be26c4f5e 100644
--- a/meta/classes/module-base.bbclass
+++ b/meta/classes/module-base.bbclass
@@ -1,5 +1,8 @@
inherit kernel-arch
+# This is instead of DEPENDS = "virtual/kernel"
+do_configure[depends] += "virtual/kernel:do_shared_workdir"
+
export OS = "${TARGET_OS}"
export CROSS_COMPILE = "${TARGET_PREFIX}"
@@ -15,8 +18,6 @@ KERNEL_OBJECT_SUFFIX = ".ko"
# kernel modules are generally machine specific
PACKAGE_ARCH = "${MACHINE_ARCH}"
-do_configure[depends] += "virtual/kernel:do_shared_workdir"
-
# Function to ensure the kernel scripts are created. Expected to
# be called before do_compile. See module.bbclass for an exmaple.
do_make_scripts() {
diff --git a/meta/classes/module.bbclass b/meta/classes/module.bbclass
index a03cc74de4..0952c0cca7 100644
--- a/meta/classes/module.bbclass
+++ b/meta/classes/module.bbclass
@@ -1,10 +1,8 @@
-DEPENDS += "virtual/kernel"
-
inherit module-base kernel-module-split
addtask make_scripts after do_patch before do_compile
do_make_scripts[lockfiles] = "${TMPDIR}/kernel-scripts.lock"
-do_make_scripts[deptask] = "do_populate_sysroot"
+do_make_scripts[depends] += "virtual/kernel:do_shared_workdir"
EXTRA_OEMAKE += "KERNEL_SRC=${STAGING_KERNEL_DIR}"
diff --git a/meta/recipes-kernel/lttng/lttng-modules_2.6.0.bb b/meta/recipes-kernel/lttng/lttng-modules_2.6.0.bb
index 4cf01caa51..420b691db1 100644
--- a/meta/recipes-kernel/lttng/lttng-modules_2.6.0.bb
+++ b/meta/recipes-kernel/lttng/lttng-modules_2.6.0.bb
@@ -6,9 +6,6 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=1412caf5a1aa90d6a48588a4794c0eac \
file://gpl-2.0.txt;md5=751419260aa954499f7abaabaa882bbe \
file://lgpl-2.1.txt;md5=243b725d71bb5df4a1e5920b344b86ad"
-DEPENDS = "virtual/kernel"
-do_configure[depends] += "virtual/kernel:do_shared_workdir"
-
inherit module
SRCREV = "1b2a5429de815c95643df2eadf91253909708728"