summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2012-07-06 22:47:27 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-08-19 10:33:08 +0100
commit9b90c8ace04c88ac6105f0bf686f9abc70fe8074 (patch)
tree09069be8c6e3fdc11aa549821687e9c34ada66a9 /meta
parent7984a9f6ccd00bf282c9eedab7ab933add68448c (diff)
downloadopenembedded-core-9b90c8ace04c88ac6105f0bf686f9abc70fe8074.tar.gz
linux-yocto: explicitly export KMETA to scripts
The kern-tools scripts can support a meta branch and directory of a name that isn't "meta", but they need the name passed through the environment variable KMETA. ensuring that KMETA is exported in the shell environment sets the stage to support flexible meta branch name. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/classes/kernel-yocto.bbclass5
-rw-r--r--meta/recipes-kernel/kern-tools/kern-tools-native_git.bb2
2 files changed, 5 insertions, 2 deletions
diff --git a/meta/classes/kernel-yocto.bbclass b/meta/classes/kernel-yocto.bbclass
index 10a8d40d9c..1b37dc781a 100644
--- a/meta/classes/kernel-yocto.bbclass
+++ b/meta/classes/kernel-yocto.bbclass
@@ -45,6 +45,7 @@ def find_urls(d):
do_patch() {
cd ${S}
+ export KMETA=${KMETA}
# if kernel tools are available in-tree, they are preferred
# and are placed on the path before any external tools. Unless
@@ -62,7 +63,7 @@ do_patch() {
if [ -n "${KMETA}" ]; then
createme_flags="--disable-meta-gen"
fi
- createme ${createme_flags} ${ARCH} ${kbranch}
+ createme ${createme_flags} --meta ${KMETA} ${ARCH} ${kbranch}
if [ $? -ne 0 ]; then
echo "ERROR. Could not create ${kbranch}"
exit 1
@@ -180,6 +181,7 @@ addtask kernel_checkout before do_patch after do_unpack
do_kernel_configme[dirs] = "${S} ${B}"
do_kernel_configme() {
echo "[INFO] doing kernel configme"
+ export KMETA=${KMETA}
if [ -n ${KCONFIG_MODE} ]; then
configmeflags=${KCONFIG_MODE}
@@ -220,6 +222,7 @@ python do_kernel_configcheck() {
# are corrected to the proper commit.
do_validate_branches() {
cd ${S}
+ export KMETA=${KMETA}
set +e
# if SRCREV is AUTOREV it shows up as AUTOINC there's nothing to
diff --git a/meta/recipes-kernel/kern-tools/kern-tools-native_git.bb b/meta/recipes-kernel/kern-tools/kern-tools-native_git.bb
index 0cb111c271..c176aed335 100644
--- a/meta/recipes-kernel/kern-tools/kern-tools-native_git.bb
+++ b/meta/recipes-kernel/kern-tools/kern-tools-native_git.bb
@@ -4,7 +4,7 @@ LIC_FILES_CHKSUM = "file://git/tools/kgit;beginline=5;endline=9;md5=d8d1d729a70c
DEPENDS = "git-native guilt-native"
-SRCREV = "12c39b76eca4ed993b5ffb38cbe89e0608b216c3"
+SRCREV = "579b1ba2169d053c1330854f54f605bb6929d6d8"
PR = "r12"
PV = "0.1+git${SRCPV}"