summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorMatthew McClintock <msm@freescale.com>2012-08-16 21:54:56 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-08-19 10:42:44 +0100
commit70b17a893bd2e1bbba8ea16619b02a60e7c4b8d8 (patch)
treeb1d1b840bb6c0adbe9894a735154b7ffdc4d3ba9 /meta
parent03136ebc529dbc82f2db14055e124114da7e84b3 (diff)
downloadopenembedded-core-70b17a893bd2e1bbba8ea16619b02a60e7c4b8d8.tar.gz
perf_3.4.bb: update to build against older kernels
Removes a make install-python_ext when not present since older versions of perf lack this install rule This also fixes a library issue on older kernels building with a newer toolchain where libaries that would previously be pulled in are no longer. So we add them manually. Signed-off-by: Matthew McClintock <msm@freescale.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-kernel/perf/perf_3.4.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta/recipes-kernel/perf/perf_3.4.bb b/meta/recipes-kernel/perf/perf_3.4.bb
index 505c7b8084..5fb38e60ed 100644
--- a/meta/recipes-kernel/perf/perf_3.4.bb
+++ b/meta/recipes-kernel/perf/perf_3.4.bb
@@ -54,6 +54,7 @@ B = "${WORKDIR}/${BPN}-${PV}"
SCRIPTING_DEFINES = "${@perf_feature_enabled('perf-scripting', '', 'NO_LIBPERL=1 NO_LIBPYTHON=1',d)}"
TUI_DEFINES = "${@perf_feature_enabled('perf-tui', '', 'NO_NEWT=1',d)}"
+export LDFLAGS = "-ldl -lutil"
EXTRA_OEMAKE = \
'-C ${S}/tools/perf \
O=${B} \
@@ -71,7 +72,8 @@ do_compile() {
do_install() {
oe_runmake DESTDIR=${D} install
- if [ "${@perf_feature_enabled('perf-scripting', 1, 0, d)}" = "1" ]; then
+ # we are checking for this make target to be compatible with older perf versions
+ if [ "${@perf_feature_enabled('perf-scripting', 1, 0, d)}" = "1" -a $(grep install-python_ext ${S}/tools/perf/Makefile) = "0"]; then
oe_runmake DESTDIR=${D} install-python_ext
fi
}