summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorYu Ke <ke.yu@intel.com>2011-07-11 15:23:19 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-07-12 14:56:34 +0100
commit603c5a241f0549da00334ac62dcbd1b0a72b6c82 (patch)
tree2ca238a6b468aedce0f6e4f7875d1996e23f9cba /meta
parentab4ae436126f20b404375c9ae77cf66cfe31ea34 (diff)
downloadopenembedded-core-603c5a241f0549da00334ac62dcbd1b0a72b6c82.tar.gz
perl: fix for non /usr/lib libdir case
the config.sh is hardcoded to be /usr/lib, which does not work in non /usr/lib libdir case. This patch replace the hard code /usr/lib with ${libdir} to fix this issue Signed-off-by: Yu Ke <ke.yu@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/perl/perl_5.12.3.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta/recipes-devtools/perl/perl_5.12.3.bb b/meta/recipes-devtools/perl/perl_5.12.3.bb
index beb179188b..4582d91144 100644
--- a/meta/recipes-devtools/perl/perl_5.12.3.bb
+++ b/meta/recipes-devtools/perl/perl_5.12.3.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://Copying;md5=2b4c6ffbcfcbdee469f02565f253d81a \
# We need gnugrep (for -I)
DEPENDS = "virtual/db grep-native"
DEPENDS += "gdbm zlib"
-PR = "r2"
+PR = "r3"
# 5.10.1 has Module::Build built-in
PROVIDES += "libmodule-build-perl"
@@ -150,6 +150,7 @@ do_configure() {
-e 's,@ARCH@-thread-multi,,g' \
-e 's,@ARCH@,${TARGET_ARCH}-${TARGET_OS},g' \
-e "s%/usr/include%${STAGING_INCDIR}%g" \
+ -e 's,/usr/lib/,${libdir}/,g' \
-e 's,/usr/,${exec_prefix}/,g' \
-e 's,/perl5,/perl,g' \
config.sh-${TARGET_ARCH}-${TARGET_OS}