summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorMatthew McClintock <msm@freescale.com>2012-08-17 12:54:07 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-08-19 10:43:31 +0100
commit48a698bf97a47a346d5b7d79c2709301e98b4c2c (patch)
tree2b1e7465b0a8145000151b1e80fdf8a1e335d62e /meta
parenta1f16a0f3a015628f3d2d02d980311537a3a2c00 (diff)
downloadopenembedded-core-48a698bf97a47a346d5b7d79c2709301e98b4c2c.tar.gz
cross-localedef-native_2.16.bb: fix for CentOS 5.X
| gcc -isystem/home/mattsm/git/poky/build-master/tmp/sysroots/x86_64-linux/usr/include -isystem/home/mattsm/git/poky/build-master/tmp/sysroots/x86_64-linux/usr/include -O2 -pipe -DNOT_IN_libc=1 -DNO_SYSCONF -DNO_UNCOMPRESS -DLOCALE_PATH='"/usr/local/lib/locale:/usr/local/share/i18n"' -DLOCALEDIR='"/usr/local/lib/locale"' -DLOCALE_ALIAS_PATH='"/usr/local/share/locale"' -DCHARMAP_PATH='"/usr/local/share/i18n/charmaps"' -DREPERTOIREMAP_PATH='"/usr/local/share/i18n/repertoiremaps"' -DLOCSRCDIR='"/usr/local/share/i18n/locales"' -DNOT_IN_libc -DIN_GLIBC_LOCALEDEF -Iglibc/locale/programs -I./include -Iglibc/locale -I. -I. -include ./include/always.h -Wall -Wno-format -c -o ld-address.o glibc/locale/programs/ld-address.c | In file included from glibc/locale/programs/localedef.h:24, | from glibc/locale/programs/ld-address.c:30: | ./include/locale.h:6: error: conflicting types for 'locale_t' | glibc/locale/xlocale.h:42: error: previous declaration of 'locale_t' was here | make: *** [ld-address.o] Error 1 | ERROR: oe_runmake failed Signed-off-by: Matthew McClintock <msm@freescale.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-core/eglibc/cross-localedef-native_2.16.bb9
-rw-r--r--meta/recipes-core/eglibc/eglibc-2.16/fix_for_centos_5.8.patch18
2 files changed, 25 insertions, 2 deletions
diff --git a/meta/recipes-core/eglibc/cross-localedef-native_2.16.bb b/meta/recipes-core/eglibc/cross-localedef-native_2.16.bb
index 47f0834003..a79a276ae4 100644
--- a/meta/recipes-core/eglibc/cross-localedef-native_2.16.bb
+++ b/meta/recipes-core/eglibc/cross-localedef-native_2.16.bb
@@ -13,10 +13,15 @@ LIC_FILES_CHKSUM = "file://${LIC_DIR}/LICENSES;md5=98a1128c4b58120182cbea3b1752d
inherit native
inherit autotools
-PR = "r0"
+# pick up an eglibc-2.16 patch
+FILESPATH = "${FILE_DIRNAME}/eglibc-${PV}"
+
+PR = "r1"
SRCREV="19383"
EGLIBC_BRANCH="eglibc-2_16"
-SRC_URI = "svn://www.eglibc.org/svn/branches/;module=${EGLIBC_BRANCH};protocol=http "
+SRC_URI = "svn://www.eglibc.org/svn/branches/;module=${EGLIBC_BRANCH};protocol=http \
+ file://fix_for_centos_5.8.patch;patchdir=.. \
+ "
S = "${WORKDIR}/${EGLIBC_BRANCH}/localedef"
do_unpack_append() {
diff --git a/meta/recipes-core/eglibc/eglibc-2.16/fix_for_centos_5.8.patch b/meta/recipes-core/eglibc/eglibc-2.16/fix_for_centos_5.8.patch
new file mode 100644
index 0000000000..7618c99534
--- /dev/null
+++ b/meta/recipes-core/eglibc/eglibc-2.16/fix_for_centos_5.8.patch
@@ -0,0 +1,18 @@
+Upstream-Status: Inappropriate [other]
+
+This is a hack to fix building the locale bits on an older
+CentOs 5.X machine
+
+Index: eglibc-2_16/libc/locale/programs/config.h
+===================================================================
+--- eglibc-2_16.orig/libc/locale/programs/config.h
++++ eglibc-2_16/libc/locale/programs/config.h
+@@ -19,6 +19,8 @@
+ #ifndef _LD_CONFIG_H
+ #define _LD_CONFIG_H 1
+
++#define DUMMY_LOCALE_T
++
+ /* Use the internal textdomain used for libc messages. */
+ #define PACKAGE _libc_intl_domainname
+ #ifndef VERSION