summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2012-06-15 15:05:41 -0700
committerSaul Wold <sgw@linux.intel.com>2012-06-19 21:59:49 -0700
commit87610064a435f8b8b5694e4d6627e53b25d8f713 (patch)
treec8786c8f60e8062bc5188c81a8b5b50236fe09c7 /meta/recipes-support
parent6d761ae17ddbd3d936e7fe985b40825ad62b2418 (diff)
downloadopenembedded-core-87610064a435f8b8b5694e4d6627e53b25d8f713.tar.gz
curl: Use gnutls for target and openssl for native
Since gnutls is available on the target use it, but we do not build gnutls for the native side as it adds too many dependecies, so use openssl. Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-support')
-rw-r--r--meta/recipes-support/curl/curl_7.24.0.bb13
1 files changed, 6 insertions, 7 deletions
diff --git a/meta/recipes-support/curl/curl_7.24.0.bb b/meta/recipes-support/curl/curl_7.24.0.bb
index f9dce7de12..2c5369c014 100644
--- a/meta/recipes-support/curl/curl_7.24.0.bb
+++ b/meta/recipes-support/curl/curl_7.24.0.bb
@@ -5,10 +5,10 @@ SECTION = "console/network"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://COPYING;beginline=7;md5=3a34942f4ae3fbf1a303160714e664ac"
-DEPENDS = "zlib gnutls openssl"
+DEPENDS = "zlib gnutls"
DEPENDS_virtclass-native = "zlib-native openssl-native"
-DEPENDS_virtclass-nativesdk = "zlib-nativesdk openssl-nativesdk"
-PR = "r1"
+DEPENDS_virtclass-nativesdk = "zlib-nativesdk"
+PR = "r2"
SRC_URI = "http://curl.haxx.se/download/curl-${PV}.tar.bz2 \
file://noldlibpath.patch \
@@ -20,7 +20,6 @@ SRC_URI[sha256sum] = "ebdb111088ff8b0e05b1d1b075e9f1608285e8105cc51e21caacf33d01
inherit autotools pkgconfig binconfig
EXTRA_OECONF = "--with-zlib=${STAGING_LIBDIR}/../ \
- --with-ssl \
--without-libssh2 \
--with-random=/dev/urandom \
--without-libidn \
@@ -28,9 +27,9 @@ EXTRA_OECONF = "--with-zlib=${STAGING_LIBDIR}/../ \
${CURLGNUTLS} \
"
-CURLGNUTLS = " --with-gnutls=${STAGING_LIBDIR}/../"
-CURLGNUTLS_virtclass-native = "--without-gnutls"
-CURLGNUTLS_virtclass-nativesdk = "--without-gnutls"
+CURLGNUTLS = " --with-gnutls=${STAGING_LIBDIR}/../ --without-ssl"
+CURLGNUTLS_virtclass-native = "--without-gnutls --with-ssl"
+CURLGNUTLS_virtclass-nativesdk = "--without-gnutls --without-ssl"
do_configure_prepend() {
sed -i s:OPT_GNUTLS/bin:OPT_GNUTLS:g configure.ac