summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2024-03-06 07:42:13 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-03-06 16:23:34 +0000
commit4d371bc44735c4e30f454b3522f785df6687a164 (patch)
tree364ce156cfc7457754a829de9aade601f0c503f9 /meta/recipes-support
parent7c60c42091a98d0c22242fb2a500b5b25f66a658 (diff)
downloadopenembedded-core-4d371bc44735c4e30f454b3522f785df6687a164.tar.gz
libusb1: upgrade 1.0.26 -> 1.0.27
Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support')
-rw-r--r--meta/recipes-support/libusb/libusb1/0001-configure.ac-Link-with-latomic-only-if-no-atomic-bui.patch46
-rw-r--r--meta/recipes-support/libusb/libusb1_1.0.27.bb (renamed from meta/recipes-support/libusb/libusb1_1.0.26.bb)7
2 files changed, 3 insertions, 50 deletions
diff --git a/meta/recipes-support/libusb/libusb1/0001-configure.ac-Link-with-latomic-only-if-no-atomic-bui.patch b/meta/recipes-support/libusb/libusb1/0001-configure.ac-Link-with-latomic-only-if-no-atomic-bui.patch
deleted file mode 100644
index 3c223e0822..0000000000
--- a/meta/recipes-support/libusb/libusb1/0001-configure.ac-Link-with-latomic-only-if-no-atomic-bui.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-From 95e601ce116dd46ea7915c171976b85ea0905d58 Mon Sep 17 00:00:00 2001
-From: Lonnie Abelbeck <lonnie@abelbeck.com>
-Date: Sun, 8 May 2022 14:05:56 -0500
-Subject: [PATCH] configure.ac: Link with -latomic only if no atomic builtins
-
-Follow-up to 561dbda, a check of GCC atomic builtins needs to be done
-first.
-
-I'm no autoconf guru, but using this:
-https://github.com/mesa3d/mesa/blob/0df485c285b73c34ba9062f0c27e55c3c702930d/configure.ac#L469
-as inspiration, I created a pre-check before calling AC_SEARCH_LIBS(...)
-
-Fixes #1135
-Closes #1139
-Upstream-Status: Backport [https://github.com/kraj/libusb/commit/95e601ce116dd46ea7915c171976b85ea0905d58]
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- configure.ac | 16 +++++++++++++++-
- libusb/version_nano.h | 2 +-
- 2 files changed, 16 insertions(+), 2 deletions(-)
-
---- a/configure.ac
-+++ b/configure.ac
-@@ -153,7 +153,21 @@ if test "x$platform" = xposix; then
- AC_SEARCH_LIBS([pthread_create], [pthread],
- [test "x$ac_cv_search_pthread_create" != "xnone required" && AC_SUBST(THREAD_LIBS, [-lpthread])],
- [], [])
-- AC_SEARCH_LIBS([__atomic_fetch_add_4], [atomic])
-+ dnl Check for new-style atomic builtins. We first check without linking to -latomic.
-+ AC_MSG_CHECKING(whether __atomic_load_n is supported)
-+ AC_LINK_IFELSE([AC_LANG_SOURCE([[
-+ #include <stdint.h>
-+ int main() {
-+ struct {
-+ uint64_t *v;
-+ } x;
-+ return (int)__atomic_load_n(x.v, __ATOMIC_ACQUIRE) &
-+ (int)__atomic_add_fetch(x.v, (uint64_t)1, __ATOMIC_ACQ_REL);
-+ }]])], GCC_ATOMIC_BUILTINS_SUPPORTED=yes, GCC_ATOMIC_BUILTINS_SUPPORTED=no)
-+ AC_MSG_RESULT($GCC_ATOMIC_BUILTINS_SUPPORTED)
-+ if test "x$GCC_ATOMIC_BUILTINS_SUPPORTED" != xyes; then
-+ AC_SEARCH_LIBS([__atomic_fetch_add_4], [atomic])
-+ fi
- elif test "x$platform" = xwindows; then
- AC_DEFINE([PLATFORM_WINDOWS], [1], [Define to 1 if compiling for a Windows platform.])
- else
diff --git a/meta/recipes-support/libusb/libusb1_1.0.26.bb b/meta/recipes-support/libusb/libusb1_1.0.27.bb
index 2af6fcdea7..f2431d75c8 100644
--- a/meta/recipes-support/libusb/libusb1_1.0.26.bb
+++ b/meta/recipes-support/libusb/libusb1_1.0.27.bb
@@ -11,14 +11,13 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
BBCLASSEXTEND = "native nativesdk"
SRC_URI = "${GITHUB_BASE_URI}/download/v${PV}/libusb-${PV}.tar.bz2 \
- file://0001-configure.ac-Link-with-latomic-only-if-no-atomic-bui.patch \
file://run-ptest \
- "
+ "
GITHUB_BASE_URI = "https://github.com/libusb/libusb/releases"
UPSTREAM_CHECK_REGEX = "releases/tag/v?(?P<pver>\d+(\.\d+)+)$"
-SRC_URI[sha256sum] = "12ce7a61fc9854d1d2a1ffe095f7b5fac19ddba095c259e6067a46500381b5a5"
+SRC_URI[sha256sum] = "ffaa41d741a8a3bee244ac8e54a72ea05bf2879663c098c82fc5757853441575"
S = "${WORKDIR}/libusb-${PV}"
@@ -41,7 +40,7 @@ do_compile_ptest() {
}
do_install_ptest() {
- install -m 755 ${B}/tests/.libs/stress ${D}${PTEST_PATH}
+ install -m 755 ${B}/tests/stress ${D}${PTEST_PATH}
}
FILES:${PN} += "${base_libdir}/*.so.*"