summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/rng-tools
diff options
context:
space:
mode:
authorwangmy <wangmy@fujitsu.com>2022-02-15 07:54:36 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-02-16 09:46:25 +0000
commit63b1c5ccd178fdd6f8af1d1b9f7fab529b1746e9 (patch)
tree95840b0be1403d69c424825cdb7f572103a8f9a4 /meta/recipes-support/rng-tools
parent1a2a64082d2a4845bebe802afed2a65dac994043 (diff)
downloadopenembedded-core-63b1c5ccd178fdd6f8af1d1b9f7fab529b1746e9.tar.gz
rng-tools: upgrade 6.14 -> 6.15
0001-Adding-ability-to-detect-non-posix-extensions-for-pt.patch 0002-Allow-for-use-of-either-pthread-affinity-set-methods.patch removed since they're included in 6.15. Changelog: ========= Adjust rngtests for better behavior in travis fix use of non-posix setaffinity call to allow building on strict posix (musl) systems Add armv6l to list of detected arches for pkcs11 misc fixes to allow building on libc-musl fix a deadlock in jitter shutdown sequence minor warning fixups (unused variables) improve cpu detection code improve jitter cpu monopolization on small/single cpu systems Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/rng-tools')
-rw-r--r--meta/recipes-support/rng-tools/rng-tools/0001-Adding-ability-to-detect-non-posix-extensions-for-pt.patch41
-rw-r--r--meta/recipes-support/rng-tools/rng-tools/0002-Allow-for-use-of-either-pthread-affinity-set-methods.patch47
-rw-r--r--meta/recipes-support/rng-tools/rng-tools_6.15.bb (renamed from meta/recipes-support/rng-tools/rng-tools_6.14.bb)4
3 files changed, 1 insertions, 91 deletions
diff --git a/meta/recipes-support/rng-tools/rng-tools/0001-Adding-ability-to-detect-non-posix-extensions-for-pt.patch b/meta/recipes-support/rng-tools/rng-tools/0001-Adding-ability-to-detect-non-posix-extensions-for-pt.patch
deleted file mode 100644
index 89edc4c403..0000000000
--- a/meta/recipes-support/rng-tools/rng-tools/0001-Adding-ability-to-detect-non-posix-extensions-for-pt.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-From 66e6adc138eef1367d7492fb79ae4da84ed62934 Mon Sep 17 00:00:00 2001
-From: Neil Horman <nhorman@gmail.com>
-Date: Thu, 15 Jul 2021 08:43:01 -0400
-Subject: [PATCH] Adding ability to detect non-posix extensions for pthreads
-
-Theres a desire to build rngd with musl, which doesn't have all the gnu
-extensions (but it has some). So test for those. Note, this requires
-the addition of the USE_EXTENSIONS macro to enable -d_GNU_SOURCE
-
-Upstream-Status: Backport
-Signed-off-by: Neil Horman <nhorman@tuxdriver.com>
-Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
----
- configure.ac | 7 +++++++
- 1 file changed, 7 insertions(+)
-
-diff --git a/configure.ac b/configure.ac
-index 9df633d..d0c2179 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -25,6 +25,7 @@ AC_CANONICAL_TARGET dnl required for broken AX_PTHREAD
- AM_INIT_AUTOMAKE([foreign])
- AC_CONFIG_HEADERS([rng-tools-config.h])
- AC_CONFIG_MACRO_DIRS([m4])
-+AC_USE_SYSTEM_EXTENSIONS
-
- dnl Parse options
-
-@@ -100,6 +101,12 @@ AS_IF(
- ], [AC_MSG_NOTICE([Disabling JITTER entropy source])]
- )
-
-+AC_CHECK_DECL(pthread_attr_setaffinity_np,
-+ [AC_DEFINE([HAVE_PTHREAD_ATTR_SETAFFINITY], 1,[Set ATTR_SETAFFINITY])],
-+ [ AC_CHECK_DECL(pthread_setaffinity_np,
-+ [AC_DEFINE([HAVE_PTHREAD_SETAFFINITY],1, [Set PTHREAD_SETAFFINITY])], [ AC_MSG_ERROR([Neither pthread_setaffinity_np nor pthread_attr_setaffinity_np found])],[[#include <pthread.h>]])
-+ ], [[#include <pthread.h>]])
-+
- AS_IF(
- [ test "x$with_nistbeacon" != "xno"],
- [
diff --git a/meta/recipes-support/rng-tools/rng-tools/0002-Allow-for-use-of-either-pthread-affinity-set-methods.patch b/meta/recipes-support/rng-tools/rng-tools/0002-Allow-for-use-of-either-pthread-affinity-set-methods.patch
deleted file mode 100644
index f7470d04bf..0000000000
--- a/meta/recipes-support/rng-tools/rng-tools/0002-Allow-for-use-of-either-pthread-affinity-set-methods.patch
+++ /dev/null
@@ -1,47 +0,0 @@
-From e4909f329245db52415102e96fc7c99ca1445d05 Mon Sep 17 00:00:00 2001
-From: Neil Horman <nhorman@gmail.com>
-Date: Thu, 15 Jul 2021 08:48:10 -0400
-Subject: [PATCH] Allow for use of either pthread affinity set methods
-
-musl has support for pthread_setaffinity_np, but not
-pthread_attr_setaffinity_np. so check for hte existence of either
-function in configure, and use the appropriate one.
-
-Upstream-Status: Backport
-Signed-off-by: Neil Horman <nhorman@tuxdriver.com>
-Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
----
- rngd_jitter.c | 15 ++++++++++++++-
- 1 file changed, 14 insertions(+), 1 deletion(-)
-
-diff --git a/rngd_jitter.c b/rngd_jitter.c
-index ea29436..5c7e09e 100644
---- a/rngd_jitter.c
-+++ b/rngd_jitter.c
-@@ -67,12 +67,25 @@ static int rngd_notime_start(void *ctx,
- for(i=i-1;i>=0;i--) {
- CPU_SET(i,cpus);
- }
-- pthread_attr_setaffinity_np(&thread_ctx->notime_pthread_attr, cpusize, cpus);
-
-+ /*
-+ * Note that only one of:
-+ * HAVE_PTHREAD_ATTR_SETAFFINITY
-+ * and
-+ * HAVE_PTHREAD_SETAFFINITY
-+ * Will ever be set, as per the configure.ac logic
-+ */
-+#ifdef HAVE_PTHREAD_ATTR_SETAFFINITY
-+ pthread_attr_setaffinity_np(&thread_ctx->notime_pthread_attr, cpusize, cpus);
-+#endif
- ret = -pthread_create(&thread_ctx->notime_thread_id,
- &thread_ctx->notime_pthread_attr,
- start_routine, arg);
-
-+#ifdef HAVE_PTHREAD_SETAFFINITY
-+ pthread_setaffinity_np(&thread_ctx->notime_thread_id, cpusize, cpus);
-+#endif
-+
- CPU_FREE(cpus);
- return ret;
- }
diff --git a/meta/recipes-support/rng-tools/rng-tools_6.14.bb b/meta/recipes-support/rng-tools/rng-tools_6.15.bb
index 222d7cc630..c4d616e29b 100644
--- a/meta/recipes-support/rng-tools/rng-tools_6.14.bb
+++ b/meta/recipes-support/rng-tools/rng-tools_6.15.bb
@@ -12,10 +12,8 @@ SRC_URI = "git://github.com/nhorman/rng-tools.git;branch=master;protocol=https \
file://init \
file://default \
file://rngd.service \
- file://0001-Adding-ability-to-detect-non-posix-extensions-for-pt.patch \
- file://0002-Allow-for-use-of-either-pthread-affinity-set-methods.patch \
"
-SRCREV = "c16176d3800b91f4d016b66733b384493b06f294"
+SRCREV = "381f69828b782afda574f259c1b7549f48f9bb77"
S = "${WORKDIR}/git"