summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/ptest-runner/ptest-runner_2.3.1.bb
diff options
context:
space:
mode:
authorAníbal Limón <anibal.limon@linaro.org>2019-01-30 11:14:32 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-01-31 09:45:25 +0000
commitf0b3fa049e0395ffc56237404f79975852ce4e4e (patch)
tree9402e98c5487e5d300513360d11a249ec9ad714f /meta/recipes-support/ptest-runner/ptest-runner_2.3.1.bb
parentd6065f136f6d353c3054cc3f440a4e259509f876 (diff)
downloadopenembedded-core-f0b3fa049e0395ffc56237404f79975852ce4e4e.tar.gz
ptest-runner: Upgrade to 2.3.1
Changeset, 05b112b utils.c: Print DURATION after ERROR acb5efb utils.c: run_child redirect stderr to stdout e1062f7 ptest-runner: make DEFAULT_DIRECTORY be able to be defined when compiling Signed-off-by: Aníbal Limón <anibal.limon@linaro.org> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/ptest-runner/ptest-runner_2.3.1.bb')
-rw-r--r--meta/recipes-support/ptest-runner/ptest-runner_2.3.1.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta/recipes-support/ptest-runner/ptest-runner_2.3.1.bb b/meta/recipes-support/ptest-runner/ptest-runner_2.3.1.bb
new file mode 100644
index 0000000000..4b7992bf2f
--- /dev/null
+++ b/meta/recipes-support/ptest-runner/ptest-runner_2.3.1.bb
@@ -0,0 +1,26 @@
+SUMMARY = "A C program to run all installed ptests"
+DESCRIPTION = "The ptest-runner2 package installs a ptest-runner \
+program which loops through all installed ptest test suites and \
+runs them in sequence."
+HOMEPAGE = "http://git.yoctoproject.org/cgit/cgit.cgi/ptest-runner2/about/"
+
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=751419260aa954499f7abaabaa882bbe"
+
+SRCREV = "05b112bda7ac2adba8e9b0f088d6e5843b148a38"
+PV = "2.3.1+git${SRCPV}"
+
+SRC_URI = "git://git.yoctoproject.org/ptest-runner2"
+S = "${WORKDIR}/git"
+
+FILES_${PN} = "${bindir}/ptest-runner"
+
+EXTRA_OEMAKE = "-e MAKEFLAGS= CFLAGS="${CFLAGS} -DDEFAULT_DIRECTORY=\\\"${libdir}\\\"""
+
+do_compile () {
+ oe_runmake
+}
+
+do_install () {
+ install -D -m 0755 ${S}/ptest-runner ${D}${bindir}/ptest-runner
+}