summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/lz4/lz4_1.7.4.bb
diff options
context:
space:
mode:
authorArmin Kuster <akuster@mvista.com>2017-04-01 13:06:44 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-05-12 08:49:29 +0100
commit962459c55406432537e10ab743cfa325b703e12a (patch)
treee8ef4d4ddbde458cba071bc545025059ec73b188 /meta/recipes-support/lz4/lz4_1.7.4.bb
parentbfbdd1a2069f199be9ba0909dd512469ff17b65e (diff)
downloadopenembedded-core-962459c55406432537e10ab743cfa325b703e12a.tar.gz
lz4: update to lastest 1.7.4
update SRC_URI: as of 1.7.3, repo changed. same owner Renamed recipe to reflect PV and added Epoch Added ptest, tests added v1.7.3 updated LICENSE to be more accurate. Signed-off-by: Armin Kuster <akuster@mvista.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-support/lz4/lz4_1.7.4.bb')
-rw-r--r--meta/recipes-support/lz4/lz4_1.7.4.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-support/lz4/lz4_1.7.4.bb b/meta/recipes-support/lz4/lz4_1.7.4.bb
new file mode 100644
index 0000000000..5ddffd54b9
--- /dev/null
+++ b/meta/recipes-support/lz4/lz4_1.7.4.bb
@@ -0,0 +1,33 @@
+SUMMARY = "Extremely Fast Compression algorithm"
+DESCRIPTION = "LZ4 is a very fast lossless compression algorithm, providing compression speed at 400 MB/s per core, scalable with multi-cores CPU. It also features an extremely fast decoder, with speed in multiple GB/s per core, typically reaching RAM speed limits on multi-core systems."
+
+LICENSE = "BSD | BSD-2-Clause | GPL-2.0"
+LIC_FILES_CHKSUM = "file://lib/LICENSE;md5=ebc2ea4814a64de7708f1571904b32cc\
+ file://programs/COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
+ file://LICENSE;md5=7f2857d58beff6d04137bf9b09e5ffb6"
+
+PE = "1"
+
+SRCREV = "7bb64ff2b69a9f8367de9ab483cdadf42b4c1b65"
+
+SRC_URI = "git://github.com/lz4/lz4.git \
+ file://run-ptest \
+"
+
+S = "${WORKDIR}/git"
+inherit ptest
+
+EXTRA_OEMAKE = "PREFIX=${prefix} CC='${CC}' DESTDIR=${D} LIBDIR=${libdir} INCLUDEDIR=${includedir}"
+
+do_install() {
+ oe_runmake install
+}
+
+do_install_ptest () {
+ install -d ${D}${PTEST_PATH}/testsuite
+ cp -rf ${S}/* ${D}${PTEST_PATH}/testsuite
+}
+
+RDEPENDS_${PN}-ptest += "make python3"
+
+BBCLASSEXTEND = "native nativesdk"