summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libpcre/files/pcre-cross.patch
diff options
context:
space:
mode:
authorFahad Usman <fahad_usman@mentor.com>2012-12-10 19:51:21 +0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-12-13 14:28:39 +0000
commit9867a9ad7a80a26654326650752dbbe89c8de3c5 (patch)
treea7e99d87caa787d4eec1bb545584deb561f324ea /meta/recipes-support/libpcre/files/pcre-cross.patch
parent57907458fe4b6c7037f35862adabf29b8ac1f029 (diff)
downloadopenembedded-core-9867a9ad7a80a26654326650752dbbe89c8de3c5.tar.gz
libpcre: Improve the recipe
- Improve the cross patch to determine *_FOR_BUILD in configure - Leverage the fact that autotools.bbclass handles *_FOR_BUILD now - Drop the now unnecessary do_compile override - Drop the do_split_packages - Split out packages for pcregrep, pcretest, in addition to libpcrecpp and libpcreposix - add nativesdk to BBCLASSEXTEND as well as native Signed-off-by: Christopher Larson <chris_larson@mentor.com> - the patch was imported from meta-mentor layer on yoctoproject git server http://git.yoctoproject.org/cgit/cgit.cgi/meta-mentor as of commit id 62f819b97e356c1d7468fbccbf3a3ceed78b09a8 - broken up the original patch in two parts, this part contains some improvements to the recipe and the cross patch Signed-off-by: Fahad Usman <fahad_usman@mentor.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-support/libpcre/files/pcre-cross.patch')
-rw-r--r--meta/recipes-support/libpcre/files/pcre-cross.patch53
1 files changed, 37 insertions, 16 deletions
diff --git a/meta/recipes-support/libpcre/files/pcre-cross.patch b/meta/recipes-support/libpcre/files/pcre-cross.patch
index 2ae05a12ca..83880f7098 100644
--- a/meta/recipes-support/libpcre/files/pcre-cross.patch
+++ b/meta/recipes-support/libpcre/files/pcre-cross.patch
@@ -1,23 +1,19 @@
-Upstream-Status: Inappropriate [configuration]
+Upstream-Status: Pending
-To be upstreamable, this patch requires check for *_FOR_BUILD, otherwise
-it needs to pass special variables.
-
-It would be nice to implement per-target compiler specification to
-automake, as it is done for linker.
-
-Even better it would be nice to implement native build time targets in
-automake.
-
-Index: pcre-7.6/Makefile.am
-===================================================================
---- pcre-7.6.orig/Makefile.am 2008-01-23 17:58:28.000000000 +0000
-+++ pcre-7.6/Makefile.am 2008-04-03 22:32:00.000000000 +0000
-@@ -147,6 +147,11 @@
+--- pcre-8.32.orig/Makefile.am
++++ pcre-8.32/Makefile.am
+@@ -197,8 +197,18 @@ bin_SCRIPTS = pcre-config
+
++CC_FOR_BUILD = @CC_FOR_BUILD@
++CFLAGS_FOR_BUILD = @CFLAGS_FOR_BUILD@
++CCLD_FOR_BUILD = @CCLD_FOR_BUILD@
++LDFLAGS_FOR_BUILD = @LDFLAGS_FOR_BUILD@
++
+ if WITH_REBUILD_CHARTABLES
noinst_PROGRAMS += dftables
dftables_SOURCES = dftables.c
-+dftables_LINK = $(LINK_FOR_BUILD) -o $@
++dftables_LINK = $(CCLD_FOR_BUILD) -o $@
+dftables_LDFLAGS = $(LDFLAGS_FOR_BUILD)
+
+dftables.o: $(srcdir)/dftables.c
@@ -25,3 +21,28 @@ Index: pcre-7.6/Makefile.am
pcre_chartables.c: dftables$(EXEEXT)
./dftables$(EXEEXT) $@
+--- pcre-8.32.orig/configure.ac
++++ pcre-8.32/configure.ac
+@@ -72,6 +72,22 @@ then
+ fi
+ fi
+
++if test x"$cross_compiling" = xyes; then
++ CC_FOR_BUILD="${CC_FOR_BUILD-gcc}"
++ CCLD_FOR_BUILD="${CCLD_FOR_BUILD-gcc}"
++ CFLAGS_FOR_BUILD="${CFLAGS_FOR_BUILD}"
++ LDFLAGS_FOR_BUILD="${LDFLAGS_FOR_BUILD}"
++else
++ CC_FOR_BUILD="${CC_FOR_BUILD-\$(CC)}"
++ CCLD_FOR_BUILD="${CCLD_FOR_BUILD-\$(CCLD)}"
++ CFLAGS_FOR_BUILD="${CFLAGS_FOR_BUILD-\$(CFLAGS)}"
++ LDFLAGS_FOR_BUILD="${LDFLAGS_FOR_BUILD-\$(LDFLAGS)}"
++fi
++AC_ARG_VAR(CC_FOR_BUILD, [build system C compiler])
++AC_ARG_VAR(CCLD_FOR_BUILD, [build system C linker frontend])
++AC_ARG_VAR(CFLAGS_FOR_BUILD, [build system C compiler arguments])
++AC_ARG_VAR(LDFLAGS_FOR_BUILD, [build system C linker frontend arguments])
++
+ # AC_PROG_CXX will return "g++" even if no c++ compiler is installed.
+ # Check for that case, and just disable c++ code if g++ doesn't run.
+ AC_LANG_PUSH(C++)