summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libcap-ng/libcap-ng-python_0.8.4.bb
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@eng.windriver.com>2024-01-02 23:06:41 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-01-07 12:24:54 +0000
commitee0eab240976f3bd0c9050694524336368c96201 (patch)
tree805d72a7eed06a91ffaaa3e08aa29ffb1a8e9293 /meta/recipes-support/libcap-ng/libcap-ng-python_0.8.4.bb
parent8d2fbe1de759d36a8aeb184aaf89bb7c14fb3760 (diff)
downloadopenembedded-core-ee0eab240976f3bd0c9050694524336368c96201.tar.gz
libcap-ng-python: upgrade 0.8.3 -> 0.8.4
ChangeLog: - In capng_change_id, clear PR_SET_KEEPCAPS if returning an error - pscap: add -p option for reporting a specified process - Annotate function prototypes to warn if results are unused - Drop python2 support * Remove "--with-python" option as python2 support was dropped. Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/libcap-ng/libcap-ng-python_0.8.4.bb')
-rw-r--r--meta/recipes-support/libcap-ng/libcap-ng-python_0.8.4.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-support/libcap-ng/libcap-ng-python_0.8.4.bb b/meta/recipes-support/libcap-ng/libcap-ng-python_0.8.4.bb
new file mode 100644
index 0000000000..4790134ae9
--- /dev/null
+++ b/meta/recipes-support/libcap-ng/libcap-ng-python_0.8.4.bb
@@ -0,0 +1,29 @@
+require libcap-ng.inc
+
+FILESEXTRAPATHS:prepend := "${THISDIR}/libcap-ng:"
+
+SUMMARY .= " - python"
+
+inherit lib_package autotools python3targetconfig
+
+# drop setuptools when version > 0.8.3 is released; it's needed only for distutils
+DEPENDS += "libcap-ng python3 swig-native python3-setuptools-native"
+
+S = "${WORKDIR}/libcap-ng-${PV}"
+
+EXTRA_OECONF += "--with-python3"
+
+do_install:append() {
+ rm -rf ${D}${bindir}
+ rm -rf ${D}${libdir}/.debug
+ rm -f ${D}${libdir}/lib*
+ rm -rf ${D}${libdir}/pkgconfig
+ rm -rf ${D}${datadir}
+ rm -rf ${D}${includedir}
+}
+
+# PACKAGES = "${PN}"
+
+FILES:${PN} = "${libdir}/python${PYTHON_BASEVERSION}"
+FILES:${PN}-dbg =+ "${PYTHON_SITEPACKAGES_DIR}/.debug/_capng.so"
+