summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/gpgme
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2013-12-04 16:40:26 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-12-05 12:32:11 +0000
commit530764d4301ee9407d20903009efc9d95cd4c3f9 (patch)
tree2dc6553071dc3efd65ea1ee14c9688e39d6b69d8 /meta/recipes-support/gpgme
parenta29c71024c304263bfb0732c870f20c1a6af7f64 (diff)
downloadopenembedded-core-530764d4301ee9407d20903009efc9d95cd4c3f9.tar.gz
gpgme: remove pth handling
pth support was removed from gpgpme in 1.3.2 according to the upstream changelog, so drop all mention of it from the recipe. Fixes the configure warning: WARNING: QA Issue: gpgme: configure was passed unrecognised options: --without-pth-test --with-pth Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/gpgme')
-rw-r--r--meta/recipes-support/gpgme/gpgme_1.4.3.bb10
1 files changed, 3 insertions, 7 deletions
diff --git a/meta/recipes-support/gpgme/gpgme_1.4.3.bb b/meta/recipes-support/gpgme/gpgme_1.4.3.bb
index aacd92383c..78182c01bd 100644
--- a/meta/recipes-support/gpgme/gpgme_1.4.3.bb
+++ b/meta/recipes-support/gpgme/gpgme_1.4.3.bb
@@ -15,16 +15,12 @@ SRC_URI = "ftp://ftp.gnupg.org/gcrypt/gpgme/gpgme-${PV}.tar.bz2 \
SRC_URI[md5sum] = "334e524cffa8af4e2f43ae8afe585672"
SRC_URI[sha256sum] = "2d1cc12411753752d9c5b9037e6fd3fd363517af720154768cc7b46b60120496"
-DEPENDS = "libgpg-error libassuan ${PTH}"
-PTH_libc-uclibc = "npth"
-PTH = "pth"
+DEPENDS = "libgpg-error libassuan"
-EXTRA_OECONF = "--with-pth=${STAGING_DIR_HOST} --without-pth-test \
- --with-gpg=${bindir}/gpg --without-gpgsm"
+EXTRA_OECONF = "--with-gpg=${bindir}/gpg --without-gpgsm"
inherit autotools binconfig
-PACKAGES =+ "${PN}-pth ${PN}-pthread"
-FILES_${PN}-pth = "${libdir}/libgpgme-pth.so.*"
+PACKAGES =+ "${PN}-pthread"
FILES_${PN}-pthread = "${libdir}/libgpgme-pthread.so.*"
FILES_${PN}-dev += "${datadir}/common-lisp/source/gpgme/*"