summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/curl
diff options
context:
space:
mode:
authorRobert Joslyn <robert.joslyn@redrectangle.org>2023-09-27 18:56:06 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-09-29 23:07:43 +0100
commit34f37de80928bb23a594268b0e996beb575ca51b (patch)
tree31b09d94a5bff8eafa413690a1b9e1564b4939b8 /meta/recipes-support/curl
parentd51fc5c8c469730885af7bbde7122032de411d89 (diff)
downloadopenembedded-core-34f37de80928bb23a594268b0e996beb575ca51b.tar.gz
curl: Skip tests marked flaky
Some tests can fail intermittently and upstream has marked these as flaky so they can easily be skipped. At present there are 12 tests marked flaky with 10 of them running in the default recipe configuration. Skip them to avoid the failures. Signed-off-by: Robert Joslyn <robert.joslyn@redrectangle.org> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com>
Diffstat (limited to 'meta/recipes-support/curl')
-rw-r--r--meta/recipes-support/curl/curl/run-ptest2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-support/curl/curl/run-ptest b/meta/recipes-support/curl/curl/run-ptest
index 95af2bd7b3..8f9c20f34d 100644
--- a/meta/recipes-support/curl/curl/run-ptest
+++ b/meta/recipes-support/curl/curl/run-ptest
@@ -1,6 +1,6 @@
#!/bin/sh
cd tests
-{ ./runtests.pl -a -n -s -j4 || echo "FAIL: curl" ; } | sed \
+{ ./runtests.pl -a -n -s -j4 !flaky || echo "FAIL: curl" ; } | sed \
-e 's|\([^ ]* *\) \([^ ]* *\)...OK|PASS: \1 \2|' \
-e 's|\([^ ]* *\) \([^ ]* *\)...FAILED|FAIL: \1 \2|' \
-e 's/Warning: test[0-9]\+ not present in tests\/data\/Makefile.inc//'