summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/curl/curl
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2023-09-17 11:38:36 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-09-18 08:53:05 +0100
commitff88f275f5f8d52da2967726d8880cbbfdfc8f19 (patch)
tree600dfba4a423909c26a951a09d811aa6494b640b /meta/recipes-support/curl/curl
parent432446ef402ff42fe0c90172b77376fa5981524a (diff)
downloadopenembedded-core-ff88f275f5f8d52da2967726d8880cbbfdfc8f19.tar.gz
curl: build and run the full set of ptests
Not running make in the top level tests/ directory excluded about a third of them (those that consisted of running small test binaries). Also, run tests in parallel, which reduces total time from five minutes to about 75 seconds. Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support/curl/curl')
-rw-r--r--meta/recipes-support/curl/curl/run-ptest2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-support/curl/curl/run-ptest b/meta/recipes-support/curl/curl/run-ptest
index 2c74c58f5d..95af2bd7b3 100644
--- a/meta/recipes-support/curl/curl/run-ptest
+++ b/meta/recipes-support/curl/curl/run-ptest
@@ -1,6 +1,6 @@
#!/bin/sh
cd tests
-{ ./runtests.pl -a -n -s || echo "FAIL: curl" ; } | sed \
+{ ./runtests.pl -a -n -s -j4 || echo "FAIL: curl" ; } | sed \
-e 's|\([^ ]* *\) \([^ ]* *\)...OK|PASS: \1 \2|' \
-e 's|\([^ ]* *\) \([^ ]* *\)...FAILED|FAIL: \1 \2|' \
-e 's/Warning: test[0-9]\+ not present in tests\/data\/Makefile.inc//'