summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/boost/bjam-native_1.66.0.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2018-02-01 20:02:01 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-02-06 10:54:41 +0000
commit18e94bc08db55afb2d9b9db9a51c6a2d5478c056 (patch)
treefa8798b765302e01e2cf0f2495b67ee414a7e6ef /meta/recipes-support/boost/bjam-native_1.66.0.bb
parentca9ec1c3d0c23fd00095f732730b1c9423b06423 (diff)
downloadopenembedded-core-18e94bc08db55afb2d9b9db9a51c6a2d5478c056.tar.gz
boost: update to 1.66.0
Rework 0002-Don-t-set-up-m32-m64-we-do-that-ourselves.patch to remove the offending bits from the function instead of removing calls to the function all over the place. Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-support/boost/bjam-native_1.66.0.bb')
-rw-r--r--meta/recipes-support/boost/bjam-native_1.66.0.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta/recipes-support/boost/bjam-native_1.66.0.bb b/meta/recipes-support/boost/bjam-native_1.66.0.bb
new file mode 100644
index 0000000000..92c86a3ef5
--- /dev/null
+++ b/meta/recipes-support/boost/bjam-native_1.66.0.bb
@@ -0,0 +1,19 @@
+require boost-${PV}.inc
+
+SUMMARY = "Portable Boost.Jam build tool for boost"
+SECTION = "devel"
+
+inherit native
+
+SRC_URI += "file://bjam-native-build-bjam.debug.patch \
+ file://0001-Fix-a-strange-assert-typo-how-was-this-released-with.patch"
+
+do_compile() {
+ ./bootstrap.sh --with-toolset=gcc
+}
+
+do_install() {
+ install -d ${D}${bindir}/
+ # install unstripped version for bjam
+ install -c -m 755 bjam.debug ${D}${bindir}/bjam
+}