summaryrefslogtreecommitdiffstats
path: root/meta/recipes-qt
diff options
context:
space:
mode:
authorDenis Carikli <denis@eukrea.com>2011-09-15 11:26:16 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-10-04 11:34:21 +0100
commit026b59180fe3fbeb43cfd143f053ef33f482ef0c (patch)
tree11a1b60d69abab165a5430c527cbd075642c83a5 /meta/recipes-qt
parent64d6a6ceceb1f1a599b8140f30071f8bc8e60393 (diff)
downloadopenembedded-core-026b59180fe3fbeb43cfd143f053ef33f482ef0c.tar.gz
qt4(embedded and x11): Disable neon for armv6-vfp
Without the -no-neon flag, neon is "autodetected" by looking if the compiler is capable of compiling a neon test, and succeed, and neon is then enabled during the compilation. Signed-off-by: Denis Carikli <denis@eukrea.com>
Diffstat (limited to 'meta/recipes-qt')
-rw-r--r--meta/recipes-qt/qt4/qt4-embedded_4.7.3.bb4
-rw-r--r--meta/recipes-qt/qt4/qt4-x11-free_4.7.3.bb4
2 files changed, 4 insertions, 4 deletions
diff --git a/meta/recipes-qt/qt4/qt4-embedded_4.7.3.bb b/meta/recipes-qt/qt4/qt4-embedded_4.7.3.bb
index c3f6713199..801b45ab82 100644
--- a/meta/recipes-qt/qt4/qt4-embedded_4.7.3.bb
+++ b/meta/recipes-qt/qt4/qt4-embedded_4.7.3.bb
@@ -1,9 +1,9 @@
require qt-${PV}.inc
require qt4-embedded.inc
-PR = "${INC_PR}.1"
+PR = "${INC_PR}.2"
-QT_CONFIG_FLAGS_append_armv6 = " -no-neon "
+QT_CONFIG_FLAGS_append_armv6-vfp = " -no-neon "
QT_CONFIG_FLAGS += " \
-exceptions \
diff --git a/meta/recipes-qt/qt4/qt4-x11-free_4.7.3.bb b/meta/recipes-qt/qt4/qt4-x11-free_4.7.3.bb
index 75c6314e7f..413afb4a2d 100644
--- a/meta/recipes-qt/qt4/qt4-x11-free_4.7.3.bb
+++ b/meta/recipes-qt/qt4/qt4-x11-free_4.7.3.bb
@@ -1,9 +1,9 @@
require qt4-x11-free.inc
require qt-${PV}.inc
-PR = "${INC_PR}.1"
+PR = "${INC_PR}.2"
-QT_CONFIG_FLAGS_append_armv6 = " -no-neon "
+QT_CONFIG_FLAGS_append_armv6-vfp = " -no-neon "
QT_CONFIG_FLAGS += " \
-no-embedded \