summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2024-04-04 16:47:01 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-04-08 23:33:03 +0100
commitd92e04c1cebd7d29a767d5862b713fa97d3e5d8e (patch)
treeaaf9e11ce176b6d92751d6d281ed29b5a5244b45 /meta/recipes-kernel
parent6059f8eb8097079142bb35fe46c55f3b6e68d1fc (diff)
downloadopenembedded-core-d92e04c1cebd7d29a767d5862b713fa97d3e5d8e.tar.gz
perf: add asm include required for v6.9+
Kernel commit 9eea8fafe33e ("libbpf: fix __arg_ctx type enforcement for perf_event programs") added with 6.9-rc1 tools/include/uapi/asm/bpf_perf_event.h which for arc, arm64, loongarch, riscv and s390 includes headers from the arch/${ARCH}/... directories. Which results in: ERROR: perf-1.0-r0 do_compile: oe_runmake failed | In file included from 1.0/perf-1.0/tools/include/uapi/linux/bpf_perf_event.h:11, | from libbpf.c:36: | perf/1.0/perf-1.0/tools/include/uapi/asm/bpf_perf_event.h:2:10: fatal error: ../../arch/arm64/include/uapi/asm/bpf_perf_event.h: No such file or directory | 2 | #include "../../arch/arm64/include/uapi/asm/bpf_perf_event.h" | | ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ We copy the uapi/asm directory to make sure the header file is present. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel')
-rw-r--r--meta/recipes-kernel/perf/perf.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-kernel/perf/perf.bb b/meta/recipes-kernel/perf/perf.bb
index 6c4ee4a208..fe96e1012b 100644
--- a/meta/recipes-kernel/perf/perf.bb
+++ b/meta/recipes-kernel/perf/perf.bb
@@ -129,6 +129,7 @@ EXTRA_OEMAKE += "\
# honour a JOBS variable.
EXTRA_OEMAKE:append:task-configure = " JOBS=1"
+# include/uapi/asm is for: include/uapi/asm/bpf_perf_event.h
PERF_SRC ?= "Makefile \
tools/arch \
tools/build \
@@ -139,6 +140,7 @@ PERF_SRC ?= "Makefile \
tools/scripts \
scripts/ \
arch/arm64/tools \
+ arch/${ARCH}/include/uapi/asm/ \
arch/${ARCH}/Makefile \
"