summaryrefslogtreecommitdiffstats
path: root/meta/recipes-kernel/lttng/lttng-modules_2.13.12.bb
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2024-04-03 14:10:32 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-04-04 14:02:24 +0100
commitf8be1a87f1a7e7de714d19a6b3afe59e6f177e7d (patch)
treee3865ef7e97b7354a44097c33e7847a5f9fe535a /meta/recipes-kernel/lttng/lttng-modules_2.13.12.bb
parentdae2667eb51ac15e6b5e965bc87fe01224256105 (diff)
downloadopenembedded-core-f8be1a87f1a7e7de714d19a6b3afe59e6f177e7d.tar.gz
lttng-modules: update to v2.13.12
We drop our previously backported patches for v6.8 kernels as they are part of the 2.13.12 release of lttng and we add backports for v6.9+ kernels. Bumping lttng-modules to version v2.13.12-7-g52eb2ee9, which comprises the following commits: 52eb2ee9 Fix: dev_base_lock removed in linux 6.9-rc1 175fe77c Fix: mm_compaction_migratepages changed in linux 6.9-rc1 303434ab Fix: ASoC add component to set_bias_level events in linux 6.9-rc1 88c4e0fe Fix: ASoC snd_doc_dapm on linux 6.9-rc1 578ab207 Fix: build kvm probe on EL 8.4+ 057ad399 Fix: support ext4_journal_start on EL 8.4+ 3ca21738 Fix: correct RHEL range for kmem_cache_free define 4ba4f0ec Version 2.13.12 1124749b docs: Add supported versions and fix-backport policy c302cf1d docs: Add links to project resources d6b75831 Fix: Correct minimum version in jbd2 SLE kernel range 9e6736d6 Fix: Handle recent SLE major version codes 5d331562 Fix: build on sles15sp4 f6800492 Compile fixes for RHEL 9.3 kernels d988f04a Fix: ext4_discard_preallocations changed in linux 6.8.0-rc3 616c60b9 Fix: btrfs_get_extent flags and compress_type changed in linux 6.8.0-rc1 8d195927 Fix: btrfs_chunk tracepoints changed in linux 6.8.0-rc1 7e8d89d1 Fix: strlcpy removed in linux 6.8.0-rc1 f4c1678d Fix: timer_start changed in linux 6.8.0-rc1 60a1e809 Fix: sched_stat_runtime changed in linux 6.8.0-rc1 Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-kernel/lttng/lttng-modules_2.13.12.bb')
-rw-r--r--meta/recipes-kernel/lttng/lttng-modules_2.13.12.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/meta/recipes-kernel/lttng/lttng-modules_2.13.12.bb b/meta/recipes-kernel/lttng/lttng-modules_2.13.12.bb
new file mode 100644
index 0000000000..95d5e2d615
--- /dev/null
+++ b/meta/recipes-kernel/lttng/lttng-modules_2.13.12.bb
@@ -0,0 +1,45 @@
+SECTION = "devel"
+SUMMARY = "Linux Trace Toolkit KERNEL MODULE"
+DESCRIPTION = "The lttng-modules 2.0 package contains the kernel tracer modules"
+HOMEPAGE = "https://lttng.org/"
+LICENSE = "LGPL-2.1-only & GPL-2.0-only & MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=0464cff101a009c403cd2ed65d01d4c4"
+
+inherit module
+
+include lttng-platforms.inc
+
+SRC_URI = "https://lttng.org/files/${BPN}/${BPN}-${PV}.tar.bz2 \
+ file://0001-Fix-ASoC-snd_doc_dapm-on-linux-6.9-rc1.patch \
+ file://0002-Fix-ASoC-add-component-to-set_bias_level-events-in-l.patch \
+ file://0003-Fix-mm_compaction_migratepages-changed-in-linux-6.9-.patch \
+ file://0004-Fix-dev_base_lock-removed-in-linux-6.9-rc1.patch \
+ "
+
+# Use :append here so that the patch is applied also when using devupstream
+SRC_URI:append = " file://0001-src-Kbuild-change-missing-CONFIG_TRACEPOINTS-to-warn.patch"
+
+SRC_URI[sha256sum] = "d85fcb66c7bd31003ab8735e8c77700e5e4f417b4c22fe1f20112cf435abad79"
+
+export INSTALL_MOD_DIR="kernel/lttng-modules"
+
+EXTRA_OEMAKE += "KERNELDIR='${STAGING_KERNEL_DIR}'"
+
+MODULES_MODULE_SYMVERS_LOCATION = "src"
+
+do_install:append() {
+ # Delete empty directories to avoid QA failures if no modules were built
+ if [ -d ${D}/${nonarch_base_libdir} ]; then
+ find ${D}/${nonarch_base_libdir} -depth -type d -empty -exec rmdir {} \;
+ fi
+}
+
+python do_package:prepend() {
+ if not os.path.exists(os.path.join(d.getVar('D'), d.getVar('nonarch_base_libdir')[1:], 'modules')):
+ bb.warn("%s: no modules were created; this may be due to CONFIG_TRACEPOINTS not being enabled in your kernel." % d.getVar('PN'))
+}
+
+BBCLASSEXTEND = "devupstream:target"
+SRC_URI:class-devupstream = "git://git.lttng.org/lttng-modules;branch=stable-2.13;protocol=https"
+SRCREV:class-devupstream = "7584cfc04914cb0842a986e9808686858b9c8630"
+SRCREV_FORMAT ?= "lttng_git"