summaryrefslogtreecommitdiffstats
path: root/meta/recipes-gnome
diff options
context:
space:
mode:
authorZhai Edwin <edwin.zhai@intel.com>2011-12-27 10:57:29 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-01-03 12:10:45 +0000
commit0343ccd64ae03245ae8ab36e7f2da95d4ee28c18 (patch)
tree7dcc9928a38e9a075ec09c38bef58cc6d5d40975 /meta/recipes-gnome
parentf33761284ddf8880bc6e69a78c62d06a286d487a (diff)
downloadopenembedded-core-0343ccd64ae03245ae8ab36e7f2da95d4ee28c18.tar.gz
gnome-keyring: fix gsettings_data_convert seg fault
gsttings_data_convert cause seg fault as gnome-keyring's schema is not installed properly. As a fix, running glib-compile-schemas from glib-utils to made "gschemas.compiled". [YOCTO #1779] got fixed. Signed-off-by: Zhai Edwin <edwin.zhai@intel.com>
Diffstat (limited to 'meta/recipes-gnome')
-rw-r--r--meta/recipes-gnome/gnome/gnome-keyring_2.32.1.bb12
1 files changed, 10 insertions, 2 deletions
diff --git a/meta/recipes-gnome/gnome/gnome-keyring_2.32.1.bb b/meta/recipes-gnome/gnome/gnome-keyring_2.32.1.bb
index cc9722598a..c40044ff97 100644
--- a/meta/recipes-gnome/gnome/gnome-keyring_2.32.1.bb
+++ b/meta/recipes-gnome/gnome/gnome-keyring_2.32.1.bb
@@ -11,12 +11,12 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
SECTION = "x11/gnome"
-PR = "r3"
+PR = "r4"
inherit autotools gnome pkgconfig
DEPENDS = "gtk+ libgcrypt libtasn1 libtasn1-native gconf ${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
-RDEPENDS_${PN} = "libgnome-keyring"
+RDEPENDS_${PN} = "libgnome-keyring glib-2.0-utils"
EXTRA_OECONF = "--disable-gtk-doc ${@base_contains('DISTRO_FEATURES', 'pam', '--enable-pam --with-pam-dir=${base_libdir}/security', '--disable-pam', d)}"
@@ -30,6 +30,14 @@ do_install_append () {
install -m 0644 ${WORKDIR}/org.gnome.keyring.service ${D}${datadir}/dbus-1/services
}
+pkg_postinst_${PN} () {
+ if [ "x$D" != "x" ]; then
+ exit 1
+ fi
+
+ test -x ${bindir}/glib-compile-schemas && glib-compile-schemas ${datadir}/glib-2.0/schemas
+}
+
FILES_${PN} += "${datadir}/dbus-1/services ${datadir}/gcr ${base_libdir}/security/*.so"
FILES_${PN}-dbg += "${libdir}/gnome-keyring/standalone/.debug/ ${base_libdir}/security/*.la"
FILES_${PN}-dbg += "${libdir}/gnome-keyring/devel/.debug/ ${base_libdir}/security/.debug"