summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-02-23 20:13:20 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-02-26 15:16:56 +0000
commit86aacbc889830846150ff2d0f1cd7ba00a2c10f6 (patch)
tree8bd579af5d9edb0ea0ae5e232b3ffffae917e43d /meta/recipes-extended
parent8e078238312948e8c7b09c66ba7a186512e995d3 (diff)
downloadopenembedded-core-86aacbc889830846150ff2d0f1cd7ba00a2c10f6.tar.gz
go-helloworld: Turn into a go module enabled build
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended')
-rw-r--r--meta/recipes-extended/go-examples/go-helloworld_0.1.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/meta/recipes-extended/go-examples/go-helloworld_0.1.bb b/meta/recipes-extended/go-examples/go-helloworld_0.1.bb
index ab70ea98a3..d3f7525dc9 100644
--- a/meta/recipes-extended/go-examples/go-helloworld_0.1.bb
+++ b/meta/recipes-extended/go-examples/go-helloworld_0.1.bb
@@ -6,13 +6,14 @@ LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
SRC_URI = "git://${GO_IMPORT}"
-SRCREV = "46695d81d1fae905a270fb7db8a4d11a334562fe"
+SRCREV = "bcf50bfd7dcd8020c90965747d857ae42802e0c5"
UPSTREAM_CHECK_COMMITS = "1"
GO_IMPORT = "github.com/golang/example"
GO_INSTALL = "${GO_IMPORT}/hello"
+GO_WORKDIR = "${GO_INSTALL}"
-inherit go
+inherit go-mod
# This is just to make clear where this example is
do_install_append() {