summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2012-06-06 18:28:02 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-06-15 15:54:18 +0100
commit1ea9b31f304e54ce4b7c2d38582d1775a46cd8c6 (patch)
tree93a05752ce2e618b4e6daf3083a6cd75a6bde4b1 /meta/recipes-extended
parente5d141fff4a96fbdac63586638fb286f263af216 (diff)
downloadopenembedded-core-1ea9b31f304e54ce4b7c2d38582d1775a46cd8c6.tar.gz
zypper: Fix build on uclibc
uclibc does not have rpmatch() so we define it if zypper is being compiled for uclibc Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta/recipes-extended')
-rw-r--r--meta/recipes-extended/zypper/zypper/rpmatch.patch23
-rw-r--r--meta/recipes-extended/zypper/zypper_git.bb2
2 files changed, 25 insertions, 0 deletions
diff --git a/meta/recipes-extended/zypper/zypper/rpmatch.patch b/meta/recipes-extended/zypper/zypper/rpmatch.patch
new file mode 100644
index 0000000000..a750a3bd39
--- /dev/null
+++ b/meta/recipes-extended/zypper/zypper/rpmatch.patch
@@ -0,0 +1,23 @@
+rpmatch() is missing in uclibc so we provide a local definition
+in form of a macro
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+Upstream-Status: Pending
+
+Index: git/src/utils/prompt.h
+===================================================================
+--- git.orig/src/utils/prompt.h 2012-06-06 15:51:00.899112775 -0700
++++ git/src/utils/prompt.h 2012-06-06 15:52:17.003116762 -0700
+@@ -172,4 +172,12 @@
+ return errstr;
+ }
+
++#ifdef __UCLIBC__
++#define rpmatch(line) \
++ ( (line == NULL)? -1 : \
++ (*line == 'y' || *line == 'Y')? 1 : \
++ (*line == 'n' || *line == 'N')? 0 : \
++ -1 )
++#endif /* __UCLIBC__ */
++
+ #endif /*ZYPPERPROMPT_H_*/
diff --git a/meta/recipes-extended/zypper/zypper_git.bb b/meta/recipes-extended/zypper/zypper_git.bb
index 0a1df5d757..c5d7c61052 100644
--- a/meta/recipes-extended/zypper/zypper_git.bb
+++ b/meta/recipes-extended/zypper/zypper_git.bb
@@ -16,6 +16,7 @@ SRC_URI = "git://github.com/openSUSE/zypper.git;protocol=git \
file://dso_linking_change_build_fix.patch \
file://rpm5-flag.patch \
file://gcc-scope.patch \
+ file://rpmatch.patch \
"
S = "${WORKDIR}/git"
@@ -25,3 +26,4 @@ RDEPENDS_${PN} = "rpm-libs"
RRECOMMENDS_${PN} = "procps util-linux-uuidgen"
PACKAGE_ARCH = "${MACHINE_ARCH}"
+OECMAKE_CXX_LINK_FLAGS_libc-uclibc += "-lintl"