summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/zypper
diff options
context:
space:
mode:
authorQing He <qing.he@intel.com>2011-01-11 17:09:12 +0800
committerSaul Wold <sgw@linux.intel.com>2011-01-30 12:09:52 -0800
commit114cee75bd4753c19b254a6d81b4d1284cbfa863 (patch)
tree81614d9759140182fd757b94461402342c33e19c /meta/recipes-extended/zypper
parent483ee172cf522969a7e5eb7f81ba2be412db9ee4 (diff)
downloadopenembedded-core-114cee75bd4753c19b254a6d81b4d1284cbfa863.tar.gz
zypper: upgrade to newer git version
this works with rpm 5.4.0 Signed-off-by: Qing He <qing.he@intel.com>
Diffstat (limited to 'meta/recipes-extended/zypper')
-rw-r--r--meta/recipes-extended/zypper/zypper/dso_linking_change_build_fix.patch6
-rw-r--r--meta/recipes-extended/zypper/zypper/rpm5-flag.patch16
-rw-r--r--meta/recipes-extended/zypper/zypper_git.bb6
3 files changed, 23 insertions, 5 deletions
diff --git a/meta/recipes-extended/zypper/zypper/dso_linking_change_build_fix.patch b/meta/recipes-extended/zypper/zypper/dso_linking_change_build_fix.patch
index 0da196f5be..a7d3fbe50c 100644
--- a/meta/recipes-extended/zypper/zypper/dso_linking_change_build_fix.patch
+++ b/meta/recipes-extended/zypper/zypper/dso_linking_change_build_fix.patch
@@ -42,8 +42,8 @@ Index: git/src/CMakeLists.txt
TARGET_LINK_LIBRARIES( zypper_lib ${ZYPP_LIBRARY} ${READLINE_LIBRARY} -laugeas ${AUGEAS_LIBRARY} )
ADD_EXECUTABLE( zypper main.cc )
--TARGET_LINK_LIBRARIES( zypper zypper_lib ${ZYPP_LIBRARY} ${READLINE_LIBRARY} -laugeas ${AUGEAS_LIBRARY} )
-+TARGET_LINK_LIBRARIES( zypper zypper_lib ${ZYPP_LIBRARY} ${READLINE_LIBRARY} -laugeas ${AUGEAS_LIBRARY} pthread rt )
+-TARGET_LINK_LIBRARIES( zypper zypper_lib ${ZYPP_LIBRARY} ${READLINE_LIBRARY} -laugeas ${AUGEAS_LIBRARY} -lrt )
++TARGET_LINK_LIBRARIES( zypper zypper_lib ${ZYPP_LIBRARY} ${READLINE_LIBRARY} -laugeas ${AUGEAS_LIBRARY} -lrt -lpthread )
INSTALL(
@@ -52,7 +52,7 @@ Index: git/src/CMakeLists.txt
# zypp-refresh utility
ADD_EXECUTABLE( zypp-refresh zypp-refresh.cc )
-TARGET_LINK_LIBRARIES( zypp-refresh ${ZYPP_LIBRARY} )
-+TARGET_LINK_LIBRARIES( zypp-refresh ${ZYPP_LIBRARY} pthread )
++TARGET_LINK_LIBRARIES( zypp-refresh ${ZYPP_LIBRARY} -lpthread )
INSTALL(
TARGETS zypp-refresh
RUNTIME DESTINATION ${INSTALL_PREFIX}/sbin
diff --git a/meta/recipes-extended/zypper/zypper/rpm5-flag.patch b/meta/recipes-extended/zypper/zypper/rpm5-flag.patch
new file mode 100644
index 0000000000..4403869cd2
--- /dev/null
+++ b/meta/recipes-extended/zypper/zypper/rpm5-flag.patch
@@ -0,0 +1,16 @@
+It's required by libzypp headers
+
+Signed-off-by: Qing He <qing.he@intel.com>
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 6b040a6..84431c8 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -15,6 +15,7 @@ INCLUDE( ${ZYPPER_SOURCE_DIR}/VERSION.cmake )
+ SET( VERSION "${VERSION_MAJOR}.${VERSION_MINOR}.${VERSION_PATCH}" )
+ ADD_DEFINITIONS( -D_FILE_OFFSET_BITS=64 )
+ ADD_DEFINITIONS( -DVERSION="${VERSION}" )
++ADD_DEFINITIONS( -D_RPM_5 )
+
+ SET( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -g -O2 -Wall -Woverloaded-virtual -fstack-protector" )
+ SET( CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -g -O2 -Wall -fstack-protector" )
diff --git a/meta/recipes-extended/zypper/zypper_git.bb b/meta/recipes-extended/zypper/zypper_git.bb
index b9e2e85943..729eabdaa8 100644
--- a/meta/recipes-extended/zypper/zypper_git.bb
+++ b/meta/recipes-extended/zypper/zypper_git.bb
@@ -12,7 +12,9 @@ inherit cmake
SRC_URI = "git://gitorious.org/opensuse/zypper.git;protocol=git \
file://cmake.patch \
- file://dso_linking_change_build_fix.patch "
+ file://dso_linking_change_build_fix.patch \
+ file://rpm5-flag.patch \
+ "
S = "${WORKDIR}/git"
-PV = "1.4.7-git${SRCPV}"
+PV = "1.5.3-git${SRCPV}"