summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/watchdog/watchdog_5.15.bb
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2018-06-13 15:58:23 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-06-18 10:59:33 +0100
commita31f8dd34e8ea34dfb087ed464575aa390ece09b (patch)
tree733f75a461a6d015cc54c62289cc9212b27cd50b /meta/recipes-extended/watchdog/watchdog_5.15.bb
parent41e4d728ef92586e2714fa0c136b838c3fda051e (diff)
downloadopenembedded-core-a31f8dd34e8ea34dfb087ed464575aa390ece09b.tar.gz
watchdog: fix init script for sysvinit
The current init script is installed from source with redhat style. It does not get configuration from /etc/default/watchdog. We should use debian style init script. Write our own script just like what wd_keepalive does. Also, in the init script, we check the existence of /dev/watchdog to determine whether to start the daemon or not. Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/watchdog/watchdog_5.15.bb')
-rw-r--r--meta/recipes-extended/watchdog/watchdog_5.15.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-extended/watchdog/watchdog_5.15.bb b/meta/recipes-extended/watchdog/watchdog_5.15.bb
index 8353ec0d20..1acab2e9e7 100644
--- a/meta/recipes-extended/watchdog/watchdog_5.15.bb
+++ b/meta/recipes-extended/watchdog/watchdog_5.15.bb
@@ -11,7 +11,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=ecc0551bf54ad97f6b541720f84d6569"
SRC_URI = "${SOURCEFORGE_MIRROR}/watchdog/watchdog-${PV}.tar.gz \
file://0001-Include-linux-param.h-for-EXEC_PAGESIZE-definition.patch \
file://0001-watchdog-remove-interdependencies-of-watchdog-and-wd.patch \
- file://watchdog-init.patch \
+ file://watchdog.init \
file://wd_keepalive.init \
"
@@ -31,7 +31,7 @@ EXTRA_OECONF += " --disable-nfs "
INITSCRIPT_PACKAGES = "${PN} ${PN}-keepalive"
-INITSCRIPT_NAME_${PN} = "watchdog.sh"
+INITSCRIPT_NAME_${PN} = "watchdog"
INITSCRIPT_PARAMS_${PN} = "start 25 1 2 3 4 5 . stop 85 0 6 ."
INITSCRIPT_NAME_${PN}-keepalive = "wd_keepalive"
@@ -49,7 +49,7 @@ do_install_append() {
install -m 0644 ${S}/debian/watchdog.service ${D}${systemd_system_unitdir}
install -m 0644 ${S}/debian/wd_keepalive.service ${D}${systemd_system_unitdir}
- install -D ${S}/redhat/watchdog.init ${D}/${sysconfdir}/init.d/watchdog.sh
+ install -Dm 0755 ${WORKDIR}/watchdog.init ${D}/${sysconfdir}/init.d/watchdog
install -Dm 0755 ${WORKDIR}/wd_keepalive.init ${D}${sysconfdir}/init.d/wd_keepalive
# watchdog.conf is provided by the watchdog-config recipe