summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/packagegroups
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2018-03-01 10:11:38 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-03-03 17:08:30 +0000
commitc9e7a276859d38aaa03845ee09428f62760ad147 (patch)
tree234b81cc44309547ef77d3aefb9e45abd0ca0f34 /meta/recipes-extended/packagegroups
parenta752aa31fc8f3a3d283381b7235710af4ece16d8 (diff)
downloadopenembedded-core-c9e7a276859d38aaa03845ee09428f62760ad147.tar.gz
libpam: be more strict about user's sanity
* replace do_pam_sanity function with distro_features_check inherit * fixes: WARNING: libpam-1.3.0-r5 do_pam_sanity: Building libpam but 'pam' isn't in DISTRO_FEATURES, PAM won't work correctly in world builds and prevents user to build libpam at all without pam in DISTRO_FEATURES, I don't see any users of this which wouldn't respect pam in DISTRO_FEATURES * only libuser is depending on libpam without respecting DISTRO_FEATURES * there are few recipes in meta-oe layers depending on libpam without respecting DISTRO_FEATURES, I've sent patch for them: samba, openwsman, pam-ssh-agent-auth, sblim-sfcb, passwdqc, python-pam, smbnetfs and omxplayer in meta-raspberrypi, I've sent PR for that one: https://github.com/agherzan/meta-raspberrypi/pull/192 * poky-lsb will need to add pam to DISTRO_FEATURES in order to build packagegroup-core-lsb Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-extended/packagegroups')
-rw-r--r--meta/recipes-extended/packagegroups/packagegroup-core-lsb.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-extended/packagegroups/packagegroup-core-lsb.bb b/meta/recipes-extended/packagegroups/packagegroup-core-lsb.bb
index 8959e3c8f4..53d100ce74 100644
--- a/meta/recipes-extended/packagegroups/packagegroup-core-lsb.bb
+++ b/meta/recipes-extended/packagegroups/packagegroup-core-lsb.bb
@@ -14,6 +14,9 @@ REQUIRED_DISTRO_FEATURES = "x11"
# libglu needs virtual/libgl, which requires opengl in DISTRO_FEATURES
REQUIRED_DISTRO_FEATURES += "opengl"
+# libpam, pam-plugin-wheel requires pam in DISTRO_FEATURES
+REQUIRED_DISTRO_FEATURES += "pam"
+
#
# We will skip parsing this packagegeoup for non-glibc systems
#