summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/lsof
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2015-06-18 15:14:16 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-06-23 11:56:17 +0100
commitab7c1d239b122c8e549e8112c88fd46c9e2b061b (patch)
tree04a9bf8936f064c0e09dd50dbb3564d525468812 /meta/recipes-extended/lsof
parent9a685d60b0549626cccea5fea8f22a57c2306f81 (diff)
downloadopenembedded-core-ab7c1d239b122c8e549e8112c88fd46c9e2b061b.tar.gz
meta: Add explict getVar param for (non) expansion
Rather than just use d.getVar(X), use the more explict d.getVar(X, False) since at some point in the future, having the default of expansion would be nice. This is the first step towards that. This patch was mostly made using the command: sed -e 's:\(getVar([^,()]*\)\s*):\1, False):g' -i `grep -ril getVar *` Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/lsof')
-rw-r--r--meta/recipes-extended/lsof/lsof_4.88.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-extended/lsof/lsof_4.88.bb b/meta/recipes-extended/lsof/lsof_4.88.bb
index bc8774f9da..c0f34b6fed 100644
--- a/meta/recipes-extended/lsof/lsof_4.88.bb
+++ b/meta/recipes-extended/lsof/lsof_4.88.bb
@@ -17,12 +17,12 @@ LIC_FILES_CHKSUM = "file://${S}/00README;beginline=645;endline=679;md5=964df275d
python do_unpack () {
# temporarily change S for unpack
# of lsof_${PV}
- s = d.getVar('S')
+ s = d.getVar('S', False)
d.setVar('S', '${WORKDIR}/lsof_${PV}')
bb.build.exec_func('base_do_unpack', d)
# temporarily change SRC_URI for unpack
# of lsof_${PV}_src
- src_uri = d.getVar('SRC_URI')
+ src_uri = d.getVar('SRC_URI', False)
d.setVar('SRC_URI', '${LOCALSRC}')
d.setVar('S', s)
bb.build.exec_func('base_do_unpack', d)