summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/lsb
diff options
context:
space:
mode:
authorPeter Kjellerstedt <peter.kjellerstedt@axis.com>2017-03-28 14:01:18 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-03-31 12:27:03 +0100
commitb791f13286c8c58ce1f3fa3745ffdd5bd5ff1d02 (patch)
tree0bae004e89030059e20ab5732c4533ed11d48577 /meta/recipes-extended/lsb
parent2799eda9f373b430ad64c8b61f8047abce7f1e22 (diff)
downloadopenembedded-core-b791f13286c8c58ce1f3fa3745ffdd5bd5ff1d02.tar.gz
lsb: Create ${base_prefix}/lib64 correctly when needed
There were two remaining cases that could end up creating /lib64 rather than ${base_prefix}/lib64. The difference matters when building with usrmerge. Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/lsb')
-rw-r--r--meta/recipes-extended/lsb/lsb_4.1.bb10
1 files changed, 5 insertions, 5 deletions
diff --git a/meta/recipes-extended/lsb/lsb_4.1.bb b/meta/recipes-extended/lsb/lsb_4.1.bb
index 2eb67b8c3a..cedf39eb65 100644
--- a/meta/recipes-extended/lsb/lsb_4.1.bb
+++ b/meta/recipes-extended/lsb/lsb_4.1.bb
@@ -97,8 +97,8 @@ do_install_append() {
ln -sf ${sbindir}/chkconfig ${D}${nonarch_libdir}/lsb/remove_initd
if [ "${TARGET_ARCH}" = "x86_64" ]; then
- if [ "${baselib}" != "lib64" ]; then
- lnr ${D}${base_libdir} ${D}/lib64
+ if [ "${base_libdir}" != "${base_prefix}/lib64" ]; then
+ lnr ${D}${base_libdir} ${D}${base_prefix}/lib64
fi
cd ${D}${base_libdir}
ln -sf ld-linux-x86-64.so.2 ld-lsb-x86-64.so.2
@@ -111,8 +111,8 @@ do_install_append() {
fi
if [ "${TARGET_ARCH}" = "powerpc64" ]; then
- if [ "${baselib}" != "lib64" ]; then
- lnr ${D}${base_libdir} ${D}/lib64
+ if [ "${base_libdir}" != "${base_prefix}/lib64" ]; then
+ lnr ${D}${base_libdir} ${D}${base_prefix}/lib64
fi
cd ${D}${base_libdir}
ln -sf ld64.so.1 ld-lsb-ppc64.so.2
@@ -125,7 +125,7 @@ do_install_append() {
fi
}
-FILES_${PN} += "${@'/lib64' if d.getVar('TARGET_ARCH') == ('x86_64' or 'powerpc64') and '${baselib}' != 'lib64' else ''} \
+FILES_${PN} += "${@'${base_prefix}/lib64' if d.getVar('TARGET_ARCH') == ('x86_64' or 'powerpc64') and '${base_libdir}' != '${base_prefix}/lib64' else ''} \
${base_libdir} \
${nonarch_libdir}/lsb \
${nonarch_base_libdir}/lsb/* \