summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/lsb/lsbtest_1.0.bb
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2012-02-24 14:51:28 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-02-28 12:14:48 +0000
commitb9ef6b8022a40bab83e8eb29e5fcde0886cf2988 (patch)
treec88293a6350b811837474fad2c2c2214f91e9c38 /meta/recipes-extended/lsb/lsbtest_1.0.bb
parentc1705317f9456f761da2094e886a07939291e53a (diff)
downloadopenembedded-core-b9ef6b8022a40bab83e8eb29e5fcde0886cf2988.tar.gz
lsbtest: Add recipe for LSB tests and automate test
The recipe is used for LSB tests. The script LSB_Test.sh does the following things: - setup LSB testing environment - download LSB rpm packages with list file packages_list from remote - install the packages - execute LSB testing with profile file session - collect the results Install packages_list and session files into ${D}/opt/lsb-test. [YOCTO #1567]
Diffstat (limited to 'meta/recipes-extended/lsb/lsbtest_1.0.bb')
-rw-r--r--meta/recipes-extended/lsb/lsbtest_1.0.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-extended/lsb/lsbtest_1.0.bb b/meta/recipes-extended/lsb/lsbtest_1.0.bb
new file mode 100644
index 0000000000..d932c831f6
--- /dev/null
+++ b/meta/recipes-extended/lsb/lsbtest_1.0.bb
@@ -0,0 +1,37 @@
+DESCRIPTION = "automate test for lsb"
+SECTION = "console/utils"
+LICENSE = "GPLv2"
+PR = "r0"
+
+LIC_FILES_CHKSUM = "file://LSB_Test.sh;beginline=3;endline=16;md5=7063bb54b04719df0716b513447f4fc0"
+
+SRC_URI = "file://LSB_Test.sh \
+ file://packages_list \
+ file://session \
+ "
+RDEPENDS_${PN} = "rpm"
+
+S=${WORKDIR}
+
+do_install() {
+ install -d ${D}/usr/bin
+ install -m 0755 ${S}/LSB_Test.sh ${D}/usr/bin
+ install -d ${D}/opt/lsb-test
+ install -m 0644 ${S}/packages_list ${D}/opt/lsb-test/packages_list
+ install -m 0644 ${S}/session ${D}/opt/lsb-test/session
+ if [ "${TARGET_ARCH}" == "i586" ];then
+ sed -i -e 's/lsbarch/ia32/g' -e 's/targetarch/i486/g' ${D}/opt/lsb-test/packages_list
+ sed -i -e 's/targetarch/x86/g' ${D}/opt/lsb-test/session
+ fi
+ if [ "${TARGET_ARCH}" == "x86_64" ];then
+ sed -i -e 's/lsbarch/amd64/g' -e 's/targetarch/x86_64/g' ${D}/opt/lsb-test/packages_list
+ sed -i -e 's/targetarch/x86-64/g' ${D}/opt/lsb-test/session
+ fi
+ if [ "${TARGET_ARCH}" == "powerpc" ];then
+ sed -i -e 's/lsbarch/ppc32/g' -e 's/targetarch/ppc/g' ${D}/opt/lsb-test/packages_list
+ sed -i -e 's/targetarch/PPC32/g' ${D}/opt/lsb-test/session
+ fi
+}
+
+FILES_${PN} += "/opt/lsb-test/* \
+ "