summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/iptables
diff options
context:
space:
mode:
authorTrevor Gamblin <trevor.gamblin@windriver.com>2022-03-17 15:22:27 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-03-18 23:32:01 +0000
commitbc41682ab2a259b7bc6a56fa3ba42907f4c8bf25 (patch)
tree1a3ea8c6871a81eaefe5ca0c4676e9ba9422f80f /meta/recipes-extended/iptables
parented2c7c806f1a48c388282f5cbdc93f034ba2c93d (diff)
downloadopenembedded-core-bc41682ab2a259b7bc6a56fa3ba42907f4c8bf25.tar.gz
iptables: use nft backend with libnftnl PACKAGECONFIG
Currently, when the libnftnl (part of meta-networking) PACKAGECONFIG is enabled for iptables, both legacy and nft-based binaries are built and installed in the image. However, the "iptables" symlink in this case still points to xtables-legacy-multi, rather than xtables-nft-multi. This patch adds a conditional check to replace the symlink to point to the latter if iptables is built with libnftnl support, which is consistent with other major distros (e.g. Fedora). The "iptables-legacy" symlink remains present and unmodified. Signed-off-by: tgamblin <trevor.gamblin@windriver.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/iptables')
-rw-r--r--meta/recipes-extended/iptables/iptables_1.8.7.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-extended/iptables/iptables_1.8.7.bb b/meta/recipes-extended/iptables/iptables_1.8.7.bb
index 839733aaa8..3b41882841 100644
--- a/meta/recipes-extended/iptables/iptables_1.8.7.bb
+++ b/meta/recipes-extended/iptables/iptables_1.8.7.bb
@@ -66,6 +66,11 @@ do_install:append() {
-e 's,@RULESDIR@,${IPTABLES_RULES_DIR},g' \
${D}${systemd_system_unitdir}/ip6tables.service
fi
+
+ # if libnftnl is included, make the iptables symlink point to the nft-based binary by default
+ if ${@bb.utils.contains('PACKAGECONFIG', 'libnftnl', 'true', 'false', d)} ; then
+ ln -sf ${sbindir}/xtables-nft-multi ${D}${sbindir}/iptables
+ fi
}
PACKAGES =+ "${PN}-modules ${PN}-apply"